Quantcast
Jump to content

plumber

2012 Trooper ECU

Recommended Posts

Can some body tell me if there 2012 trooper ECU is a siemens or continental and is this the number S11- 3605010JA-E4

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By nascarcamshaft
      I have a 2009 Trooper that when I first start it it runs great but after about a min it starts to cut out under acceleration but clears out when it gets revved up.  I downloaded the manual from   Joyner-usa.com   but it doesn't help much,  Mine doesn't have a OBD port on it and my son who is a mechanic said he can wire one in if we have a wiring diagram for the CPU but the wiring diagram of the CPU that is in the manual is for a 3 cylinder engine.  The manual talks about a MIL light that can flash out a code but I don't know where that is and even if I did find it they  don't tell me how to read it.  I have tried the coil and the map sensor and that didn't help I checked the TPS and it checks OK.  I emailed Joyner and all I got from them is there should be a OBD port on it and then they said they checked and found some don't have it,  No help from them. Anybody run into this problem or know were I can turn to get some help on this, even a good wiring diagram of the CPU would be a big help.
      Thanks for you help
    • By Weathered
      We have been having all kinds of fuel issues with this ranger.  When you try to start it when it is cold outside, it does not want to start.  It will crank over fine but doesn't start but if you stop and come back 10 minutes later or so, it will start up.  But even then, it is idling real bad.  Usually will die a few times before you can get going, really have to feather the gas pedal to keep it alive.  Once it gets warmed up, it does start better but something still not right.  Even when it is warm outside, it will start up but just doesn't idle right.
      I bought a fuel pump kit, not the whole assembly, just the pump and replaced that and the same thing happens.  I am in the process of trying to check the fuel pressure on it but the fuel pressure gauge I got from our local auto parts store seems to be defective.  Had it hooked up and can't get the gauge to show any pressure at all yet it will still start up.   If it does have the correct pressure, what would be the next place to start looking at?  If it doesn't have correct pressure, is there something else on the assembly that would cause low pressure?  We checked the voltage on the connecter and one gets 12 volts for just a few seconds and the other one gets 4.9 volts.  The other 2 show nothing.  I am guessing the one with 4.9 volts is for the fuel gauge sender and the one that has 12 volts is the pump.   When you take the fuel line off on the engine side and turn the key on, how far should it throw fuel out?  
      We have taken it to 2 shops and neither one was able to do anything with it, one said there was nothing wrong.  Not sure if they really did any checking or what or they just don't know what to do with it.  
      Would the whole fuel pump assembly out of a ranger 570 work with the ranger 800?  Would I be able to swap them without any issues?  To buy a whole new assembly, it's around $400, don't really want to spend that much not knowing if it will fix it or not.  
    • By fettman1176
      Hello there, I have 4 T2 troopers, 2 of them start and run like Champs, 2 of them have the issue. They will crank and crank but not start. Takes about 20 to 30 minutes to get them going, then they will run all day long and fire up at will every time. It's just the cold start they have a problem with. Since I have 2 that run good, I have swapped every part you can think of from the fuel system to ignition system with no success. I'm pretty stumped and am looking for any advice 
    • By Robynne Catheron
      Just wanted to say hi. I'm very thankful for this forum, because I recently purchased a 2012 Cub Cadet Volunteer.  I need to be able to maintain it myself instead of having a shop come and get it. The closest shop is about 50 miles away. I appreciate any and all help and advice! 
      I hope I don't wear out my welcome here. 
    • By Robynne Catheron
      New-to-me 2012 CC Volunteer throttle cable broke during the wicked cold snap we had a few weeks ago (upstate NY). It was already a bit sticky, but at least it was usable. 
      Is it possible to replace it myself, or must I pay to have it hauled 50 miles to the nearest shop?  I can access both ends, but the majority of it is pretty buried from the top and underneath. 
      Any advice would be appreciated. 


×
×
  • Create New...