Quantcast
Jump to content

sutcliffesa

WTB 04 Mule 3000 carb

Recommended Posts

Somebody was nice enough to steal the carb off of our VFD's mule. We run entirely off of member donations so buying a new one would be a bit painful. Anybody got a used one to sell? I can rebuild it no prob.

Thanks.

Chief Sutcliffe

HOPVFD

Smithville, TX 78957

P.S. They were nice enough to leave me the airbox, covers and all the linkages and screws.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • Travis' Mule 550

      Before Crank un-installedPiston INSTALLED after honing.Crank installed after honing.   Last pic is honed. Kind of blurry, took it with one hand. It looks better in person. It may not be professional quality but im 99.99999999999999999% sure it will work. Did better than I thought i would.   So now, only ONE more obstacle. the crankshaft axial play adjustment BUT I need someones opinion ( i took the piston back out afterwards) not sure if you can see it, but in the picture with cylinder honed, it's almost right where the  glare from the light is, and on top of the cylinder directly across from the spot, it looks like the hone didn't get ruffed up.  any ideas? out of round cylinder, cylinder wore and needs bored??  

      By Travis, in Kawasaki UTV SxS Forum

      • 68 replies
      • 1,080 views
    • new member

      just joined the forum today,have been an offroader for many years ,moved into a utv about 5 years ago & enjoy it very much.we usually ride Ocala national forest g the cooler winter months,camping as often as we can & trail riding . we enjoy meeting new friends with same interests .living in the Tampa Bay area .

      By digger, in New Members Area

      • 5 replies
      • 94 views
    • A Stubborn Mule: Mule 2500, electrical and other questions

      HI! Thanks for the forum. I am currently installing a turn signal and horn kit on a Mule 2500 that was gifted to the local ranch owner. His health is not so great, and other than a car, he has no other way to get into town. The driveway is a mile long...  Attached are some photos. The prior owner disconnected the parking brake light grounding/indicator cable. I fixed it and reconnected it (shown in photo). Following the wiring harness, there is a 6-pin block (see second photo) up front, nothing plugged into it. I have what I think, is a fairly accurate wiring diagram. Problems: I cannot find the VIN anywhere on the vehicle. I have no paperwork on it and neither does the owner. We know who owned it previously but he doesn't have paperwork on it either. I have looked NUMEROUS places, and googled it. I do not know the year. There does not seem to be any indicator light for the parking brake. I think the light was physically removed from the dash (see third photo). What parts are missing? What are they named/part numbers if you have them? What I have done so far: Fixed the parking brake switch Fixed the brake lights, the wiring in the back was pulled out, cut, a mess. (fixed) Added a third center high brake light, tying it to the wiring harness. Positioned just below the air intake. (added) Added bright red LED strip lights, at the inner side of the rear downtubes, to be used later for the turn signal indicators. Ready to order a $15 steering column strap-on switch for hazards and turn signals. Image descriptions: Parking brake switch (fixed) What are these? They were bundled up underneath the dash with a ziptie. The beige block has the red wire return from the parking brake. Wiring diagram. These seem close to the existing vehicle. Dash photo. So you can see what is missing and let me know.

      By John Mason, in Kawasaki UTV SxS Forum

      • 13 replies
      • 827 views
    • Kawasaki mule submerged in water !!help.

      Any 1 with some good advice ,my Kawasaki 2017 mule side by side was submerged in water and now dead. What can i do ?  

      By Harry Thomas, in Kawasaki UTV SxS Forum

        
      • 9 replies
      • 975 views
    • kaf620-e3 kawasaki mule side by side

      Hey all my mule runs great until it gets hot then  just quits. won't start back have to plug battery in to charge it up seems like the  battery doesn't recharge when it is running.

      By marypippin14, in UTV General Discussion

      • 5 replies
      • 196 views
×