Quantcast
Jump to content

sackspeed

Python 800i Suspension upgrade ?

Recommended Posts

Hi Guys - we have a Joyner Python 800i which we use offroad here in Scotland.

The standard shock absorbers we can get in the UK are only lasting a few days and we are struggling to find uprated ones which will fit straight on - can anyone advise on good replacements or send me a link please ?

Thanks

Alan

post-3428-0-32567700-1447412856_thumb.jpg

Share this post


Link to post
Share on other sites


That is a sweet ride.

You gotta take them off and get a fully extended and compressed measurement. Then you should be able to match them up with a namebrand shock like fox, king, walker evan etc.

Joyner uses Chinese shocks with metric diameters. It would be best to get all new springs as well. With the correct valving and spring rates your machine will ride 1000 percent better. Here in the States I used Offroad Warehouse. They can help get you close to what you need. I drive a trooper so what I am using won't help.

Share this post


Link to post
Share on other sites

If you are having trouble with the mounts not being the right size find a spacer and sleeve the bolt then drill your mounts to accommodate the size of the spacer.

Share this post


Link to post
Share on other sites

Thanks guys bit the bullet and ordered these from Joyner - first class guys to deal with arrived in 4 days from Arizona to Scotland !

Alan

post-3428-0-81268300-1448651501_thumb.jpg

Share this post


Link to post
Share on other sites

Silverbullet

We have a test trooper with Yearben brand shocks.We are trying to see if they hold up.So far so good they seem to be built with go quality parts.Only time will tell.

Thank You

Rich

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dan B
      Does anyone know if Joyner USA in Phoenix AZ is still in business.  Can't get onto their website.  The FB postings are over 1 year old.  Doesn't seem like the owner is interested in keeping customers interested or updated in what's going on.  Hasn't been at the Riverview address in a couple of years.  Last I knew, he was on S 18 St.  There's a website that says Joyner USA is at the 3700 block of E Roeser.  Don't know at the moment if it is the same business.  I bought a couple of wheels from him last year and I want to buy two more.
    • By MMaster
      Have a new r4 approx 800 miles just noticed the tach wont sweep with ignition on but the speedo does, also will start with out the clutch engaged.  my 2012 r4 tach and speedo both sweep and it wont start unless the clutch is engaged , any ideas why?. Any help would be greatly appreciated.  Thanks Matt
    • By Terrypenton
      Bought this machine a couple years ago and the gages didn’t work.  I have troubleshot this thing numerous times to no avail. Thought it may be a common ground so I individually grounded  the gages, didn’t work.  I have tested the sending units.  All have some resistance that changes as the engine revs or gets warmer.  Please help me.  Thanks in advance
    • By xbodyman
      Does any one have a wire color code on wires one the rear relays on a trooper 2 2008 model i had a lower relay on  the rear fuse block  melt down so i pulled the wire couldnt remember so i looked and thought the black with read was ground any way its a mess please help if you can thanks  Bodyman  ps also were do people get parts now days i could use a fuel sender thanks agin
  • Similar Tagged Content

    • By TmJoyner
      New to the Joyner community.  Bought a used 2016 1100 sand viper in descent shape. Only 155 miles.   Runs great.  It just rattles quite a bit in the front when riding on rough gravel / hard-packed dirt roads outside St Johns.  Removed front wheels and seems to be coming from both upper and lower suspension arm bushings/radial bearings (see pic); both left and right.  Seems like some play inside the eyelets - as I shake the arms a bit.  I assume it's not supposed be loose in there like that and the bushing/bearings are worn.  Anyone have had this issue and how did you go about changing them?
       

    • By Michael Kinlaw
      I have a 2016 R4 and I was about to load it on my trailer and the steering just broke I think. My front wheels are both pointing outwards. Does this mean front differential broke?  I jacked it up and got them both pointing in the right direction. When up in the air they work together. But as soon as I put back on the ground and move it a few feet they separate again. 
    • By Rapidray4x4
      I need help locating a rear cv style driveline for my early 2008 t4 trooper. I have broken 2 ujoints now and almost put a hole in the oil pan! I found one place but they wont return my calls. The mud season started and i got a big paper weight. Any help is greatly appreciated by me and my family.
    • By fettman1176
      Hello fellow Joyner dudes, i am looking for any ideas or pics on some doors my Trooper fleet. Any advice would be appreciated.

    • By Dan B
      Tried to remove my skid plate to access the engine oil drain plug.  The plug isn't near an access hole but located between two holes.  Can't get a wrench in to remove the plug.  Short of drilling a new access hole (which I'm seriously considering), has any one been able to remove the skid plate?  Seems to be a nut on the other end of the screw and there's no way I can access that nut.  They must have bolted the skid plate on before putting the engine into the frame.  Thanks in advance.


×
×
  • Create New...