Quantcast
Jump to content


650 Commando Rear Differential + Ring and Pinion set available


Recommended Posts

Dear 650 Commando users,

Please kindly note that there will be producition on Joyner 650 Rear Differntial and it's Ring and pinion set at the end of this month.

Anyone who is interested to get either the complete 650 Commando rear differential or the ring and pinion set please send your email to [email protected]. We will close collecting the order demand at the last day of July. Production lead time will be about 40 days and then we will ship the parts you ordered to your door using DHL Express.

As we know 650 rear differential and its parts are difficult to get now. Please take this chance when you can.

Wish you all a good day

Casey

Leaf Asia

2016-07-20

Link to comment
Share on other sites

Rich,

I think you misunderstood. I didn't mean to compete with any one.

There is no doubt that you can be my customer and have your price level. There is no conflict at all.

I just want to help as more 650 Commando user to fix their differential problem and at the same time help my partner ( the differential manufacturer, who ask me to collect demand in market)

Let's work together to help more Joyner users. And I hope you do good business.

Have a nice day

Casey

Leaf Asia

2016-07-21

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Retired Plumber
      The rear differential lock light is on and I would like to get it off. How do I do that it is a Coleman UTV700.
    • By Bill12345
      🙂 2022 hot seat Pioneer 1000-5 trail
    • By great8redsfan
      Okay folks. I have a low power issue. Been like this for a few years. Place I work at bought 3 and all have lost most of the pulling power.  They gave them away after local shop worked on one for 3 months and it had great power for about 1 month and then crap. They replaced throttle body, fuel injector, spark plug and IAC motor. Seat belt switches have wires cut and left open so no seat belt warning light anymore. It revs to 6k rpm in neutral but when put in gear and take off in low it just doesn’t seem to want to go anymore. Running 93 octane fuel with Stabil.  Any ideas greatly appreciated. I dont have a scan tool but no codes on dash. If held to floor it pops a little and runs almost 5K rpm but if I let off pedal about an inch it smoothed out and revs up to 6k rpm. 
    • By Werhat
      Hi folks,
      I have a Mule 550 (FE290D engine) that sat for several years and would not start.  A few years ago I replaced the fuel filter and carburetor, at which point it started right up and developed full power.  More recently, I've changed the air filter, fuel pump, ignition coil (gapped to spec), and spark plug, and adjusted the valves.  The engine still has a lope/surge at part throttle and at idle.  Rather than idling at a stable speed, it speeds up and slows down until it quits.  It snaps to life right away if I open the throttle, so I don't think it's starved of fuel.  I can always get it to restart immediately if I choke it while cranking, then it will die after several seconds again.  It takes some cranking to start hot when not choked.  I've tried adjusting the idle mixture, but no setting seems to make it stable.  It won't idle at all with the throttle fully closed; I have to turn the stop screw to hold it slightly open.
      I suspect it's getting idle air, since the passages are open, but that the idle jet isn't providing adequate fuel, such that I am having to hold the throttle open and idle it off the main jet which isn't stable.  This is just speculation.  I've cleaned the idle jet and tried a larger size, but it made zero difference.  The carburetor seems to be clean.  It's been doing this since I installed the new carb.  The gas tank seems to be clean, although it's hard to see inside.
      I posted a video of what it's doing:
      What's next?  Try another carburetor?
      Thanks.
       
    • By Kevin R
      Has anyone heard if there are any plans for a flip-up windshield for the Segway Villain sx10?
       
×
×
  • Create New...