Quantcast
Jump to content

Recommended Posts





Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • Hisun 750 crew 2016

      I have a 2016 750 crew (it is a Cub Cadet but same machine). It has 108 hours, 49 miles. Basically new, but I got it used with 22 miles on it. The guy said it was too big, and that he wanted a RZR. It ran great for a little over a year. It then developed a rough idle and won't wind up to get past about 20 mph in high range. I have tried countless things, and I keep coming back to overfueling. It doesn' seem to be throwing a code.  I have done the following... Spark plug (multiple times) Check, clean air filter  Sprayed brake clean around intake while running (to be sure it isn' sucking air). Checked valve adjustment Replaced fuel pump assy., after breaking it trying to remove to check in tank filter. Checked wiring and connections Checked/cleaned spark arrestor screen Replaced fuel, trying different octane.  Checked compression. Compression should be 1200 kpa,  mine was between 700 and 800 kpa.  Also noticed oil had been increasing and is now milky looking. I figured gas in oil due to overfueling. Dad said milky or foamy meant coolant in oil so we figured blown head gasket. So, we put a new head gasket on it. Old one didn't look blown. Valves were tight like new, could still see cross hatch marks in cylinder wall (like new as it IS still new!) Put it all back together, torqued bolts properly etc... no change. Still runs poorly, compression still low! I don't think it is a compression issue. We pulled the rocker cover back off to check out the automatic compression release that we had noticed on the timing chain  sproket on the end of the camshaft. It seems to be working properly. Then a lightbulb went off. "Automatic compression release" appears to slightly open an exhaust valve... when?... while cranking engine to start. There is no way that we're going to get 1200 kpa compression (unless I were to back that exhaust valve way off)! I may try that when I re-install the rocker cover.   Anyway, I'm pretty convinced that it is fuel in the oil, and that it is over fueling like I originally suspected. But how do I know the cause?? Book says over fueling could be caused by Air Pressure sensor, o2 sensor, Solar Term door position fault, or ECU program error or damage. Those are some pricey parts.  Any input??  

      By Budmanbiker, in Hisun UTV SxS Forum

        
      • 9 replies
      • 1,016 views
    • 2008 hisun rear axles

      Are the yamaha rhino rear axles the same I have a 2008 big muddy made by hisun and the rear axles for hisun are expensive and the rhino is about half the price? Thanks if anyone has info

      By Charles Newton Jr., in Hisun UTV SxS Forum

      • 1 reply
      • 212 views
    • Wanted: Trooper Axle Parts

      I am interested in any old trooper axle parts you may have lying around. Please let me know if your want to sell them.  Backstory: Hey everyone. Last trip out to moab I climbed a wall on poison spyder Mesa while 2 rzr xp1000's and three can am x3 xrc's watched me and didn't dare try. After doing it once I pulled around to show them it wasn't a fluke. One on the can am x3 xrc drivers just looked at me and said "that's steep". On the second try I spread the bell on the left rear axle. I made the climb but now the inner cage slips inside making a loud popping noise as twisting the boot. I mainly just need the inner bell but I am interested in anything you have. 

      By 2scoops, in Joyner UTV SxS Forum

      • 1 reply
      • 227 views
    • POLARIS RZR PARTS FOR SALE..POST HERE

      If anyone has any parts for sell Please list here by REPLY. I would like to see this RZR forum get moving a bit.Its worth a shot.

      By mayorOFsalem, in UTV Off-Road Classifieds - Buy & Sell

      • 14 replies
      • 7,592 views
    • 2016 Joyner T2 1100cc 4 wheel drive

      I have a 2016 Joyner T2 that is giving me problems engaging in and out of 4 wheel drive.  I have read some older posts that address this issue on some older models, but can't get any of the older pics to open for a good explanation.   I have not taken anything apart at this point.  Hoping some mechanically savvy Joyner owners can help me out. Thanks

      By Snatchy, in Joyner UTV SxS Forum

        
      • 1 reply
      • 227 views


×