Quantcast
Jump to content

Joyner trooper breaks problems..


Tobie1987
 Share

Recommended Posts

Has anyone replaced there brakes with something different..??? I only have 2 calipers working.. I bought two new master cylinders and still the same problem.. I'm only getting pressure out of one master cylinder.. I have bled them like 5 times and still nothing..

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

have you taken the master cylinder apart and reassembled it, have you adjusted the shafts that fits into the master cylinders so they make quick contact as you step on the brake, I am assuming you have the dual master cylinders, I had 2 on my 08, just one on my  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By J Gill
      any suggestions? my 2019 mule sx fi wont idle down completely, I have to lift the box and flick the throttle lever and it comes back down.
    • By Ric Silveira
      Got me a New Coleman Outfitter 2021 400
      and joining here to hopefully learn lots about it.
      I understand it's not top of the line but couldn't offord other. I'll be using it for riding around the neighborhood and light off reading here in Southwest Florida and not planing on beating it just some fun with my wife
    • By Susana
      I changed the rectifier regulator in my 2019 massimo Tboss 410 which was burnt out and still nothing. Battery is charged. The screen is dead no noise. Could the starter relay need to be changed as well? Please help me
    • By Chuck Winburn
      I bought an axis 500 brand new, hauled it home and the light indicator for 4 wheel drive is not working.  Is there a something the store didnt tell me, or is it messed up right off the assembly line? Any thoughts or advice is greatly appreciated. Thank you!
    • eManualOnline
    • By IslandHopper
      Can anyone tell me if their MSU 500 or 700 fuel pump and injector cycle when you turn the key on? This will help me rule out the Crank Position Sensor as a problem.
      I just bought this non-running and the service manual is not much help.
      Thanks

×
×
  • Create New...