Quantcast
Jump to content

Tuning a 400cc Hisun 2012 model


Davo
 Share

Recommended Posts

I recently (like yesterday) bought a secondhand  hisun  400cc 4x4 SxS. It’s a one owner 2012 model only done 125 kms. It runs rough and won’t idle  for long without cutting out., even when it’s warm.  Here’s what I’ve done to try to sort it without success: cleaned air filters, cleaned spark plug, emptied old fuel and replaced, replaced fuel filters. I notice that there is a hose coming from the carburettor (on drivers side). It goes to a T piece but  neither branch connects to anything and I can’t seem to find any places where they would naturally attach.  Any suggestions appreciated. Davo918C0C8D-431B-4911-9ACB-A9C06A41CBA9.thumb.jpeg.0e006118ec010177de33f5da10e1670d.jpeg8CA2C4F0-2F28-4483-933E-A91EA738B0FF.thumb.jpeg.b295eb8d8da8488833e608fd3f430f53.jpeg

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...
  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...