Quantcast
Jump to content

brothaman

Kawasaki 4010 (Gas) Revs/Puleses at top speed.

Recommended Posts

Not sure I'm explaining that right. but,.. I'll start with some history.  I bought the 4x4 4010 mule with a bad motor.  I built the engine.  Bottom end up.  Fresh bearings, Pistons, etc.  Cranks up and runs with no issues.  However,.. doesn't seem to run faster than 20 mph and pulses at top speed like something is up with the governor.  It feels like its cutting back.  Climbing and pulling it seems to be fine,. It pulls hard and doesn't cut up.  But on the road flat out  Cuts back/Chugs/pulses/Revs. 

Not sure where to start. Kinda tired of thinking about it. Any Ideas?

Just a mention, I'm not trying to make it faster, just fixed.  25mph it good by me.  Hell,... for my purposes I'm fine with 20 mph as long as its' running properly.

Share this post


Link to post
Share on other sites


Welcome to the UTV Board!

 the top speed is supposed to right at 25mph.

First off, whenever i have this similar problem with any engine, i start by running  some carb cleaner through it (pour proper amount or whole can in gas tank)  i usually do half a can for 4 gallon tank. and if that don't work

 i would check your valve clearances, check your manual for specs.

 Someone more experienced than me should come along soon. and will probably have a better idea than me.

 

Share this post


Link to post
Share on other sites

Top end should be in spec.  I'll run some cleaner through it.  Maybe an injector is clogged...  If that doesn't work, I might recheck the top end.  

 

  • Like 1

Share this post


Link to post
Share on other sites

So, I've learned some more about this thing.  I bought the SXS from Sunbelt who leases these to construction companies.  I was told they are locked down to 17 mph for construction site work.  I clock 18 mph uphill by GPS.  Not sure how true that is, but my contact there says this is the case.  I don't see any aftermarket device attached like the dynatech thing I've seen.  

Could this be set at the ECM?
Can the ECM be reset to Factory specs?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By bjones
      2007 Mule 610,  owned for 8 yrs and valves were ticking when I got it and had them adjusted twice and this is when plugs began to foul.  I replaced battery (used battery I had on hand) a yr ago and didn't foul a plug for some time and replaced batter (new) with a bigger lawn mower type battery again a month ago and have fouled two plug since.  Had carb cleaned and valves adjusted and still fouls plugs way to often.  Friend has a mule just like mine and his does same thing. Have read this is a common problem with 610 mule.  Any help or suggestions would be welcomed.  Thanks and stay healthy.
    • By Hisunsadman
      Last October we were sitting at an idle on a Sunday morning and it died for the first time since we time since we bought it new I've already sent it to the shop because it's under warranty after trying to fix it. New fuel injector new spark plug couldn't do a compression check because I couldn't find anything to fit it but now that it's at the shop I have a feeling that the exhaust valves tighten themselves up and they are not closing anybody ever have this problem?
    • By Travis
      View File Kawasaki Mule 550,520,500 Engine repair manual
      This file contains all specifications,troubleshooting and repair procedures for the FE290D  (9.5H.P,286cc) engine used in the  Mule 500,520 and 550 models.
      Topics covered include,  general information, service data, disassembly, reassembly,inspection of parts and maintenance.
      Notes:
      Make sure you're reading the correct information as this manual covers multiple FE series engine, some of which were not used in Mules, the manual does a very good job of clarifying which specifications and procedures are for which Model engine.
       
      Submitter Travis Submitted 01/13/2021 Category Kawasaki  
    • By Travis
      Hi, all, I am here to say i have found an excellent source for kawasaki parts, It's run by  Eddie Babbit. It is called Kawasaki Partshouse. run by Babbits online, Muskegon Michigan. http://www.kawasakipartshouse.com/oemparts
      Just the other day i ordered piston rings, for my Mule 550, They got here and a Oil ring, and smaller ring were missing from the box, Kawasaki took responsibility for the "Accident" and  I had also contacted babbits, and they replied and they said" keep the old rings, order a new set and you just pay shipping" so i got $30 piston rings for 8.95!!!? Free shipping on orders over $50!!!
       
    • By Dennis
      I have  a bulldog i bought from home depot in 2013.  In the last season it started refusing to shift from neutral to either forward or reverse.  I changed the trans axle fluid and made sure the cables were lubricated and free.  With a lot of coaxing, I can sometimes get it to shift.  once I start driving it, things improve until I let it set awhile.   Any suggestion on where to go from here?


×
×
  • Create New...