Quantcast
Jump to content

MSU500 popping/snapping sound


Markus_K
 Share

Recommended Posts

Hi everyone,

Been driving my Massimo since January. Really pretty satisfied with it. I have done 1 oil change on it and have now over 1700 miles on it. I have one leaking seal on the axle at the diff, but that is pretty much it. I do have a curious thing that happens occasionally. When turning or coming in or off a trail at a pretty severe side angle, I get an occasional snapping sound. This sound is pretty loud  and can be felt in the footwell area. It doesn't seem to really affect anthing and there is no obvious or easily seen area where some kind of movement is happening. I'm wondering if the leaking diff seal is related to this popping sound. Could the axle be pulling out of the diff?

Thanks for any help

Mark

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By Liv4upoutdoors
      Has any one replaced their radiator fan to the Massimo 410.  My buck is overheating.   I checked fuse which was good... then  I was going to jump the fan switch and have it run all the time but its not turning on.  So much for the easy fix.   I guess my next step is to replace the fan.  I would like to get the same fan so its easy to switch out.  There isn't alot of room to work in there.   So trying to make it alittle easier.  Thank you kindly for your input.  
       
    • By Tiff Rumsey
      I own a 2020 T-Boss410 I'm having problems with it over heating with it just idling for maybe 10 minutes, I have checked the fan and it works. I wired the fan up to a switch so it runs all the time and it still over heats within 10 minutes. Anyone have suggestions?
    • By res2fr
      Hello All,
       
       I am trying to find a Scanner that is works for a 2016 MSU500. I found the Tiny Scan TS301 that looks like a decent Scanner but so far have not been able to get confirmation that this works on and older model. It has been stated that it works on the 2019 and newer but not sure about older models. It appears that the ECM/ECU/EFI modules are likely interchangeable between a 2016 and the newer 2019 and on but not sure of the Scanner. I am waiting for feedback from Hisun on this issue right now.
       If this unit is not usable for my model year has anyone found and a Diagnostic Scanner for the older machines, one that works and is Affordable?
      Thanks for reading my post and any information that you may have to share,
      Robert
    • By Byron Johnson
      Does anyone have a had time starting there utv.
      I have a T-Boss 750 and I have had to put 2 starters in and put heavier wire to the starter but it still has a problem starting. it will turn over and than die before it wil turn over again. could it be that there is to much compression that might cause this problem
       
      Thank you
    • eManualOnline
    • By TTWacker
      Any help appreciated….
      I have a 2015 Massimo Gunner 250s that I had to do the top end on. I can’t find a correct video or manual that matches the timing marks this one has for the chain and cam gear. Does anyone have the correct marks to line up???
  • Similar Tagged Content

    • By TmJoyner
      New to the Joyner community.  Bought a used 2016 1100 sand viper in descent shape. Only 155 miles.   Runs great.  It just rattles quite a bit in the front when riding on rough gravel / hard-packed dirt roads outside St Johns.  Removed front wheels and seems to be coming from both upper and lower suspension arm bushings/radial bearings (see pic); both left and right.  Seems like some play inside the eyelets - as I shake the arms a bit.  I assume it's not supposed be loose in there like that and the bushing/bearings are worn.  Anyone have had this issue and how did you go about changing them?
       

    • By TimmyBoy
      Polaris XP 1000 Turbo front and rear stock suspension, good condition, no ball joints in a-arms, take offs, installed LT kit, will separate front and rear but will not sell just part of front or rear

    • By sackspeed
      Hi Guys - we have a Joyner Python 800i which we use offroad here in Scotland.

      The standard shock absorbers we can get in the UK are only lasting a few days and we are struggling to find uprated ones which will fit straight on - can anyone advise on good replacements or send me a link please ?
      Thanks
      Alan

    • By nrm5108
      I got a full set of King 2.0 shocks in great condition. They were just serviced 100 miles ago so they are still very fresh. The set also comes with a extra set of rear springs that are a little bit softer than what is on it now. Looking to get $1400 but I am open to any offers.




    • By bvcracing
      Hey guys we purchased this for a 2013 RZR800S and decided to not use them , going a different direction

      The price is 1995 plus freight for these

      will do $1599 Shipped to your door

      these are brand new never installed

      Please PM me if interested..

  • Gallery Images


×
×
  • Create New...