Quantcast
Jump to content

2011 yardsport


johnney
 Share

Recommended Posts

I got ahold of hisun out of texas, they told me it is because of the oil I've been using........ I was using regular sae 30 weight , they told be it has to be wet clutch oil or motor cycle or oils used in diesel engine .............. who would have thunk

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By Bret4207
      2019 Coleman Outfitter 550, 160-ish hours. Was driving it slowly and it just slowed down and died. Won't start. Pops once as soon as I start cranking and that's it. I have great blue white spark on the spark tester, jumps 1/2". Changed injector, no joy. Changed plugs to new several times, no joy. Pulled injector power wire and tried ether through air intake after removing air filters- nothing! I do notice if I put my hand over the air intake where the filter goes, I get pressure  pushing back at me. Jumped time? Stuck valve? Is there a decompressor on this that could be malfunc?
       
      This is the one I've had that was inop for months and months while Coleman tried to find someone to fix it. Warranty is long expired now. I'll never have anything good to say about this thing.
    • By IslandHopper
      Can anyone tell me if their MSU 500 or 700 fuel pump and injector cycle when you turn the key on? This will help me rule out the Crank Position Sensor as a problem.
      I just bought this non-running and the service manual is not much help.
      Thanks
    • By Jacob E freeman
      I have a 2018 cub cadet challenger 750 I bought brand new almost 2 years ago the first month I had it the exhaust broke and burnt the spark plug wire in two that was a recall so the dealership installed the new one it had a different design and it bolted up to the bottom two plugs below the spark plug the dealership said they had to Adjust the exhaust valves I get the machine back thanking everything is good now wrong not even a week after I get it back the timing chain tensioner comes apart inside the motor I take it back to the dealership They put one on I get the machine back thanking everything is good but then just like before not even a week goes by when I was riding the Machine automatically quits going come to find out the wet clutch was burned up the primary clutch head stripped off of the splines I get that fixed and then  it overheats I take it back they bleed the air out of the coolant they bring it back to me the same day that I get it back it overheats again I take it back they temporarily fix it again just enough to let the warranty run out and now the machine has been to multiple different mechanics I have had them try to bleed the air out they have stood it up on its end I have had the water pump changed I have had the fan hooked to a switch so I could leave it on all the time but still almost 2 years later not even 200 hours on the machine and I cannot ride it The dealership will not take it back as a lemon I have tried I am at my wits end I have no clue what to try next
    • By JacobG
      I bought a used 2015 Coleman HS400UTV-2. I assume this has a wet clutch and plan to use Mobile 1 T4 oil. Any feedback would be appreciated. 
    • eManualOnline
    • By Mikeboz
      So I am doing the first oil change and after removing the filter I noticed a little spring and what appears to be some type of retainer that attaches to the oil filter my question is how the heck do you line that back up when you put that filter back on?


  • Gallery Images


×
×
  • Create New...