Quantcast
Jump to content

2016 challenger 700 Rattle noise


WTraywick

Recommended Posts

  • 1 month later...
  • 3 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Alex
      View File 2016 Yamaha Wolverine 700 Service Manual
      2016 Yamaha Wolverine 700 Service Manual
      YX70EPNG
      YXE70WPXG
      YXE70WPHG
      YXE70WDXG
      YXE700E
      Submitter Alex Submitted 03/02/2024 Category Yamaha  
    • By amiracle40995
      I’m getting a 700-7 every startup. I’m having to change the plug every 100 miles on 93 octane gas. I got a lower numbered plug that is supposed to burn hotter. I’m wondering why that comes up every time I start it and if it’s related? I included a picture of the code or whatever it is. I haven’t seen the code in the owners manual or the hisun shop manual I have. 

    • By Rusty Beavers
      I'm working on a Coleman UTV 400 that has a rough idle, owner has had it for about a year. When I say it has a rough idle, it doesn't have the continuous smooth running sound. At times you can hear it kinda skip, sputter, or like the RPM has fallen (RPM stay constant according to the gauge) It's not as bad as it was after I replaced the fuel filter and fuel injector (both are Chiki) not sure if that is a quality brand at this point. Checked the spark plug, it was a little foul, but not too bad. (Since the engine is still idling bad I'm going to replace that) Cleaned the throttle body making sure the carbon and soot has been removed, and the air-filter has been cleaned. New fuel is being used so it's not old or been standing. They did tell me that they were using non-ethanol fuel, not sure if that would be causing the issue. Next two things I can think of that maybe the issue is the O2 sensor or the valves need adjusting.
      Thoughts and suggestions? Thanks in advance.
    • By UTVSurvey
      Hello! I am a University of Notre Dame student and have been enlisted by Lippert Components INC. to help them understand you, Side-by-side users. Taking the survey in the link below would help us to help you in improving the buying experience of Side-by-sides. Thank you so much for your attention and participation.   https://nd.qualtrics.com/jfe/form/SV_aYrwsZyjs2ZHK3I
    • By Wesley
      I have a 2022 500 Hisun product, I have had them in the past. I change my oil myself and trying to drain through the hole where I remove the plug is a mess.  How does everyone keep the belly pan clean during the oil and filter service?
       
      Wes Jackson
×
×
  • Create New...