Quantcast
Jump to content


Let There be light!


Travis

Recommended Posts

 

 Put some new headlights on my Mule!! L.E.D  lights,  i did my homework before buying them, they draw the exact same amount of power as the OEM, but are way brighter. i can see alot better now!

 Pictures soon.

 So if anyone is interested in some used but still working Kawasaki MULE 550  headlights, $15 each and they're yours!! or i'll keep them for the tractor or something...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Travis
      Many people have issues with the kawasaki FJ400 engine  fouling out spark plugs, after  working on a  few FJ engines and 600 series Mule's with this issue,  i can say the fix for this issue is using a slightly hotter spark plug... the factory recommends a BPR6ES NGK plug.... the Number in NGK plugs represents its heat range and somewhat odd, the lower the number the hotter the plug, at least as far as NGK is concerned. If you have  a Mule fouling spark plugs try installing a NGK BPR4ES spark plug.
      FROM NGK
      A hotter heat range spark plug has an insulator design with a longer heat flow path to the metal shell of the plug. As a result, more heat stays in the ceramic firing end and less is dissipated to the engine. A colder heat range spark plug has an insulator design with a shorter heat flow path to the metal shell of the plug. As a result, less heat stays in the ceramic firing end and more is dissipated to the engine. For a spark plug to function properly, it must have a tip temperature high enough to burn off carbon deposits (self-cleaning) and avoid fouling, while remaining low enough to avoid overheating the ceramic firing end and pre-ignition.
    • By Alien10
      I have a Coleman Outfitter 550 purchased in January 2022 that runs and operates pretty well.  65 hours on it so far.   It is a work vehicle for my 10 hilly acres with two 1 acre woods and 5 acres of "lawn".  The rest is under a lake. 
      My parking brake does not seem to have any grip.  It worked when new but after a month or so, it is just almost useless.     I press the parking brake pedal hard until it stops. Still, it won't hold even on slight inclines.   I don't see the caliper move as I press the brake pedal down.  There seems to be plenty of pad left on it and the rotor is shiny as if it is rubbing a little when applied, but not enough to stop it from rolling. 
      Any thoughts on possible causes? 
       
    • By Mark T
      MY 400 is gutless. I would like to know if I can upgrade to a larger engine ?
    • By TomW
      I had a problem 6-8 mo ago when the unit would not start . But you could see power on the dash. The starter solenoid was replaced and it has been fine until yesterday. When I started it up I noticed a high pitched noise coming from under the front. Like a alarmbuzz ..It seemed to drive fine so I went ahead and used it off and on for a hour or so . The noise would not go away . I parked it in the shed and lifted the hood . It seemed to be coming from the battery compartment ( where the new starter solenoid is) I jiggled the connections and the noise changed timbre and then the machine went dead. No power at all . No lights . When you cross the two poles on the starter solenoid ( previously last year it would start and run ) nothing. Checked the battery and it is fully charged . I checked the fuses inside the battery box and they all looked good  but I must be missing something. Anyone have a clue what I need to do next to R&R. The closest repair place is 2 hours away in Mississippi . Any help would be appreciated.
    • By NDV45
      I have  2008 Cub Cadet Volunteer Tracker.  Was running fine, parked and next morning electric fuel pump inop.  Checked voltage had 4.2 volts.  Swapped relays in fuse box, checked all fuses (good) and still low voltage.   Does the ECU control the voltage to the fuel pump or which relay controls the voltage to the pump?
      Have checked all wiring and not found any place it could be shorted (not saying I may have missed something). I am at a loss.  Need Help Please.
×
×
  • Create New...