Quantcast
Jump to content

Recommended Posts

HI, I have a textron stampede 900x  & my gauges were flashing on & off intermittently also headlights occasionally. Somewhere I saw to check grounds there are at least 3 .Well the one right of the negative battery terminal was loose,so I wiggle the cables a little bolt head for ground to frame broke off no effort. must have been over torqued from factory. Check those ground it's easy to do. Only problem is bolt thread was broken off in frame, easy fix, get a self tapping screw about 1/8" in diameter and drill it into frame. You have to use the heavy duty ones,like roofers use. I sanded the frame a little also . It could leave you stranded so check them.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites


That's a good tip, even for a car. I'm a member on several car forums, and it's a common problem. Sometimes it just causes overall mahem, nothing specific, just electrical gremlins. Ends up being a faulty ground connection.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Driver72
      It seems like a perfect middle ground between the Kawasaki Mule Ranch Edition and the Polaris General 4 1000  .
      But I can't find any reviews for this thing or who makes it's engine.
      It looks great, seems like an awesome SxS, but would love some insight.  If you have any experience with this rig, please chime in.
      Thanks
    • By BAER
      Have a lot of problems shifting gears on a hill, anyone have this problem 
    • By Kristi Dorrity
      We just bought a 2014 Massimo 1100 with only 27 drive hours on it. We took it out a couple of times and then the check engine light came on. We took it to an authorized massimo shop and they can't figure out what's wrong. Any advice?! We are in Utah. 
    • By bmoody4550
      Hello,
      I have changed the battery , alternator and the regulator.
      I have the red battery light on indicating it is not charging.
      Is there something else that could be the problem to my battery not charging??
      Thanks
      Bill


×
×
  • Create New...