Quantcast
Jump to content


New Hisun Owner


ArrowLobber

Recommended Posts

I'm new to this forum. I recently picked up a Hisun "Coleman" Trail Tamer 800 that was ran way too hard. Trying to learn as much as I can about Hisuns. I have done a complete engine rebuild, replaced the crank, con rods, pistons, rings, head gaskets, base gaskets. cam chains, U joints, front a-arms, replaced all rear pads, repacked trailing arm bearings. Replaced the rear diff with a used one, have a rebuild kit in the cabinet. Put it all together, no spark. Somehow got spark and fuel and it started and purred like a kitten. Pulled the exhaust off to replace the gaskets, replaced the battery and starting relay switch. Turns over but no spark and no fuel again. Have taken apart almost every connection and added grease, still nothing. So jumped on this forum to try and apply any learnings from here to my project. I'm about to pull all of my hair out and Ima already going bald. Any help and input is GREATLY appreciated.

Arrow Lobber

Link to comment
Share on other sites

Alright, there should be a kill wire that goes to the magneto, find it, and if possible un plug it, then try to start it. If it does something is wrong with the wire its self (shorting somewhere) or your ignition system, if does not start with The kill wire disconnected most likely a faulty coil.

And did you set The air gap properly?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By kgs
      Got a hisun sector 550 2019 that's got 5900 Miles on it, this year it started to getting hard to start in morning, once I get it started it works good the rest of the day. But to start it in the morning I got to hold the gas pedal to the floor and it will fire up. I replaced the fuel injector but didn't help it. So I just ordered a new air filter and 02 sensor and a maf sensor to put on it to see if this will fix it. Anyone else had this problem. I'm hoping the parts I ordered will fix it. I also bought a new battery to put in it also.
    • By Anthony Vigil
      Can anyone tell me how they grease the drivelines ?  Can’t grease the u joints. Do you need to take the driveline off ? 
      And are they easy to take off?
      Thanks
    • By didgeridoo
      Hello, All!  I've decided to replace the traction batteries in my 2018 Sector E1 with a 48V Lithium set. They may be expensive, but I figure the Discovery Dry Cell are, too. I am not looking for the max driving range, as I have never received near the brochured range to begin with, but a good mix of charge/ get work done/ charge is what I am expecting.
      I have settled on the 48V EAGL kit from bigbattery dot com. Each battery pack provides 30Ah. The kit ships with a charger, as well. The packs would be physically connected in parallel (using a busbar) to one another, maintaining the 48V voltage, but together would be able to provide the amp draw the buggy pulls when going up hill or towing a rake (rated 320 max continuous Amps). This is in comparison to the serial connection the eight 6V lead batteries. Each of the EAGL batteries looks to have its own BMS; am I correct in thinking I will have to use their included charger rather than (simply) changing the onboard charger to lithium mode? The chemistry of the pack is LiFe PO4, for what it's worth.  I haven't torn anything apart yet (to diagram), so  I am not sure how the dash will interpret the AMP draw, but the kit I am looking at includes a dash mounted charge indicator.
      If anyone has completed a similar conversion, do you have any tips? Specifically, how did you remove the original batteries, and how did you secure the new ones? I am guessing that almost any change from the stock batteries would involve at least some modifications. Any tips would be appreciated, especially things I may have failed to consider. Thanks!
    • By Blackwellok
      Hi from oklahoma
      Does anyone else own  a coleman unit. ?
       
    • By Alien10
      I have a Coleman Outfitter 550 purchased in January 2022 that runs and operates pretty well.  65 hours on it so far.   It is a work vehicle for my 10 hilly acres with two 1 acre woods and 5 acres of "lawn".  The rest is under a lake. 
      My parking brake does not seem to have any grip.  It worked when new but after a month or so, it is just almost useless.     I press the parking brake pedal hard until it stops. Still, it won't hold even on slight inclines.   I don't see the caliper move as I press the brake pedal down.  There seems to be plenty of pad left on it and the rotor is shiny as if it is rubbing a little when applied, but not enough to stop it from rolling. 
      Any thoughts on possible causes? 
       
×
×
  • Create New...