Quantcast
Jump to content

Moosehunter

2019 Hisun sector 750 Parking brake mod

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Honda533
      Machine sat and had multiple rodent chews thru out the wiring that we fixed.  Also replaced the Following: ECU, Coil and Plug Wire, small Control Box that contains fuses and relays.  Pick Up coil test at 219 ohms which is typically good on most machines but i can't find the specific manual on this thing to get the spec.  Battery good, cranks fine but the fuel pump doesn't prime or run and no spark.  Tested pump with direct 12volts and it works.  If we supply a ground to the pump it primes and works but still no spark.  We have traced all wiring including grounding and all is good. Tested key switch.  I has (4) positions.  1 - off, 2 - does nothing, 3 - powers up everything (lighting and odometer and powers ECU, 4 - starts engine.  The key switch only has 3 wires. 12v in from battery and 2 - 12v out which is power to the system and send 12v to starter relay coil.
      Are these electrical systems actually switching the grounds on and off vs the traditional switching the 12v+ on and off.  
      at my wits end with this thing. 
       
      Also when we figure this problem out we will post the solution.  seems 90% of people that ask for help on these forums, never post the fix which make this pointless.
    • By erk mann
      Bike was flooded in tropical storm.  Replaced ecu and coil. Motor turns over but no spark have 12volts on one wire of coil. How much voltage should be on other small wire? Crank position sensor is about 200ohms. . Cleaned plug with sandpaper. Want a wiring diagram to check voltage at ecu. I have update. The blue wire going to coil has no voltage when turning it over. The white with black stripe has 12vdc when key is turned to on position.also, how do I clean the connectors on ecu? I dont see how I can get a  screwdriver in there  to release them. Found a schematic.i still need to clean connectors though

    • By Locking Diff
      I just purchased a new 2019 Massimo T-Boss 410 March 2020. I haven't figured out how to unlock the differential?  There isn't a switch?
    • By Bobbyd40
      Purchased it used a week ago.  Found that it wont start from key but will start if solenoid jumped. Also noticed that brake lights don't work checked switch and its working, may be the no start problem from key. 
      Turn signals and hazards do not work headlights tail lights and hi beams all work. 
      have a manual but it is hard to decipher. 
      Hoping that someone has run into these issues and can point me in the right direction with the lights. I believe if i can get brake lights to work it may solve starting from key issue. 
      Thanks


       
    • By cliffyk
      I had mentioned in a previous post that I had removed the front anti-roll bar from my 2020 Outfitter 400; I ran that way for a month or so without noticing any downside however recently I installed a 'suicide knob" (see below) to assist my Parkinson's disease affected arms in turning the beast--but after doing so i found that in the quicker, tighter turns the knob permitted the vehicle would nosedive a bit, dig in, and plow  on hard surfaces--not scary, but quite noticeably.
      So I put the bar back on. Then today I got about 1-1/2 miles down the main road on the nearby power lines, turned around and came home to take it off--with the bar on, at 25 to 30 MPH, the front-end of the beast jumped like rabbit at each bump in either wheel rut., for a nearly brutal and quite uncomfortable ride. the bar (20 mm solid steel) is far too robust for the weight of the vehicle. The front bar on my 3900 lb. Infinity M37 is 30 mm...
      suicide knob--for you younger folks:

  • Similar Tagged Content

    • By John Maloney
      The seat belts have a safety feature that make the utv not be able to go over 15 mph if the buckles aren't latched.
      2020 hisun 250 sector
    • By Matthew Gray
      Hey there tried to search the forum and come up with nothing, I know i have seen it here. 
      What  is the Delphi code reader needed to Diagnose a 2018 Hisun Sector 750, got one with spark, fuel and no run. bit bizzare.
      Would like to get a code reader from alixpress or amazon or something as we don't have a local dealer, can anyone help me with a part number, or know of a good unit that works?
      thanks very much
      Matthew
    • By Mac250
      Just purchased a 2018 Hisun Sector 250. The gear shift is hard to engage. Tried depressing the brake pedal, no change. Tried with the engine running and turned off, no change. The gear shift cable, from the dash to the trans seems to be grinding. With my hand on the cable I can feel it grinding, vibrating, as the gear shift is moved up or down. Can this cable be removed and greased or does it just need to be replaced?
    • By JDH
      Hi guys,
      I have a Rural King version of the Hisun Sector 250 with about 75 miles and 15 hours on it.  It just started being difficult to start and idle.  But if I hold in on the gas a little it will start and run until I left off.  It also runs good and will run good until I stop then it idles for a few seconds then quits.  Its about 4 months out of warranty.  Battery voltage is fine before, during, and after starting.  Oil is clean and clear.  Gas is fresh.   I can hear the fuel pump spool up when I turn the key to actually start it, not when I turn it to the on position though like on most other UTV's I have owned.  Its really odd and has me perplexed.  The only other thing that I have noticed is that the engine temp indicator on the left side of the dash only indicates one bar regardless of how warm the engine is.  Other than that, it runs great.  Just hard to start and won't idle.  Any suggestions?  It has me  perplexed.
      Thanks
       
      Jason
    • By Kevin Slack
      I bought the sector hisun 550 for feeding deer, haven't had it a year yet and yesterday driving it I heard a bad noise. Took it back where I bought it and they said it sounds like the rear differential went out of it. Has anyone had any problem like this with there new hisun. I do have about 160 hours on it and 2600 miles. All easy driving miles.


×
×
  • Create New...