Quantcast
Jump to content

Sign in to follow this  
UTVBoard News

Tread Lightly! Auctions Donated Items for the Holidays

Recommended Posts

Featured Item: New digital Nikon D40 SLR Camera with Nikkor Lens generously donated by our friends at Jeep®.

The nonprofit organization Tread Lightly! has saved 21 donated items to auction off on eBay. All proceeds will go to keep the great outdoors beautiful, healthy, and open to the public. Bids start at 40%-60% off retail prices. So bid today to [...]

View the full article

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By dalerio007
      i have a 2017 cub cadet challenger 750 camo, after a month of nonstop work with the pandemic i was finally getting a chance to ride it. it would not start, the battery was dead, went to charge the battery and noticed a mouse had chewed a yellow wire one of2 going to a block of some kind in battery box, it is tied into the 2 fuse relay breakers  attached to the starter relay. there is a red with stripe wire that goes to a harness below the rectifier in engine compartment, it has no power to it with multimeter and the fuse block is getting real hot. other than that the dash lights up, but no readout and the gauges dont cycle, the fuel pump does not start. on the fuel pump i checked the red wires to the cdi and both have contact and are intact but one does  not have power when the key is on and there is no spark  i tried starting fluid. i have swapped out the cdi from my cousins  same year and model, also the ecu and the main relay. i have no idea where to look now. his has broke the shim again and will not start. also i did notice that i wiggled a wire connector going to a sensor on the engine and a couple lights came on on the dash, the stirring wheel one and check engine but only did it once and i cant get it to do it again. i have looked over the harness for anymore damage and have found none.
      has anyone seen this problem before, is it wiring? ground? what do i need to check next. the place i bought it has no service the guy said he could only swap parts and try. sent me to another place over an hour from me  and that guy on the phone said he was covered up and didnt know when he could look at it so he must be busy lol. besides i dont want to have them charge me $3000 to replace everything on it before they get going.
      my advice is do not buy a cub cadet, we thought we were getting a cub cadet and it turns out it is a cheap chinese pos. i still love my cub but wish i had known this before i bought it and i would not have.
      any help would be appreciated thanks
    • By JDH
      Hi guys,
      I have a Rural King version of the Hisun Sector 250 with about 75 miles and 15 hours on it.  It just started being difficult to start and idle.  But if I hold in on the gas a little it will start and run until I left off.  It also runs good and will run good until I stop then it idles for a few seconds then quits.  Its about 4 months out of warranty.  Battery voltage is fine before, during, and after starting.  Oil is clean and clear.  Gas is fresh.   I can hear the fuel pump spool up when I turn the key to actually start it, not when I turn it to the on position though like on most other UTV's I have owned.  Its really odd and has me perplexed.  The only other thing that I have noticed is that the engine temp indicator on the left side of the dash only indicates one bar regardless of how warm the engine is.  Other than that, it runs great.  Just hard to start and won't idle.  Any suggestions?  It has me  perplexed.
      Thanks
       
      Jason
    • By johnpeter
      2016 Polaris RZR  On Ebay
      https://www.ebay.com/itm/2016-Polaris-RZR-170/202382224119?
       


    • By Lenny Reed
      Any ideas on mounting a Go-pro camera
    • By Fireman2343
      Ends Sunday, bidding starts off at $1, sells to highest bidder over 24 pictures, 14 videos over 100 mph www.ebay.com/itm/123052023530
      No reserve street legal dune buggy
      on eBay bid to win #123052023530
       
      602-326-3936 any questions 
       
       

      Vw mendeola Sandrail Vw Buggy dune rzr Polaris can am yxz sand car turbo 4x4 




×
×
  • Create New...