Quantcast
Jump to content

David Trost

Massimo 2017 MSU500 won't idle when fuel is not topped off.

Recommended Posts

Interesting problem.   My Massimo runs great - but when the fuel level drops just a bit, it just stops.    It restarts easily, but I have to keep my foot on the accelerator pedal.   When I top it off with gas, it again runs fine.   I already replaced the fuel pump, but that didn't work.

Thanks for your help!

Share this post


Link to post
Share on other sites


If a pickup tube in the gas tank were disconnected or maybe cracked, that could explain why the engine quits after the fuel level drops (to a point where the fuel pump is pumping air).  The fuel pump draws fuel from the bottom of the tank.  But that doesn't explain why the engine runs if you hold a little accelerator pedal.  Is the fuel tank vent tube plugged somewhere between the fuel tank and the charcoal canister?  Remove the fuel filler cap to see if a vacuum in the tank is causing a loss of fuel supply.  Is the carburetor getting adequate fuel?

  • Like 2

Share this post


Link to post
Share on other sites

I just watched a YouTube video on your fuel gauge problem.  Might or might not be of help.

https://www.youtube.com/watch?v=dy6IQOE5UEA

On your other problem with the engine not running when fuel is slightly low, make sure your fuel lines (supply and return) are not swapped on top of the fuel pump.  I don't know if it is physically possible, but it's worth checking out.

Share this post


Link to post
Share on other sites
On 11/8/2020 at 10:35 AM, David Trost said:

Interesting problem.   My Massimo runs great - but when the fuel level drops just a bit, it just stops.    It restarts easily, but I have to keep my foot on the accelerator pedal.   When I top it off with gas, it again runs fine.   I already replaced the fuel pump, but that didn't work.

Thanks for your help!

Try blowing out injector.  Mine  did same thing. Had plastic particles in it I’m guessing from inside gas tank as it’s all plastic anyway, maybe a burr from injection machine that form it??  Mine since idles fine after warming up a few seconds. Hope this info helps!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Locking Diff
      I just purchased a new 2019 Massimo T-Boss 410 March 2020. I haven't figured out how to unlock the differential?  There isn't a switch?
    • By Regretting my choices
      Hello.  I purchased this unit as a "non runner" with the intent of using the frame to build a go-cart, but once I got it home it seemed way to good to part out.  The motor cranks over, and I have spark, but no fuel.  If I put a little fuel in the cylinder it fires up until that fuel is burnt, then of course it dies.  The fuel pump is not running and I have removed the plug and there is no power going to it.  I have checked the safety switch on the brake pedal and its fine, I have checked the fuses, all good, but am not sure where to go from here. The shifter is missing on the unit, but the indicator light on the dash shows its in neutral, and the e-brake indicator switch is working as well.  I am thinking of jumping power to the fuel pump next to see if it runs and if the motor will start.
      What am I missing?  What can stop the fuel pump from getting power to it?
       
       
    • By ANIL SEDALI
      Hi friends. I'm Anıl. I live in Turkey. I have a Hisun 700 UTV 2015 Models. My problem is : 
      inability to change gear after the engine has started. Before the engine starts, it can shift into all gears; but after running, I cannot change gear. At about 3000 km. Fuel injection model. Can anyone help on this topic? Thank you!
    • By Bentley76
      I am working on a ride for a friend of mine, it is a Gunner 250. Machine was parked last year because it wouldn't idle right. It would idle way up then back down to almost stalling so they parked it. His kid now wants to ride it again so we've gotten it out. First thing we did was drain old gas and re-fill. Changed filter and spark plug. It will start right up but immediately dies. Checked for fuel pressure it and it is good. You can spray starting fluid in fuel injection and it will do the same thing. Fires right up then dies. Anyone have a clue what this could be? I appreciate any help I can get! Thanks
    • By Liv4upoutdoors
      I just got an enclosure today from Vista Quad Gear on Amazon.  I'm sharing this info because I was surprised at the quality of it and the price.  It came a week early.   I put it on today.  Its not perfect.  I need to extend the bottom of the door toward the front step but other then that I'm extremely happy with.   Front by the windshield is about 2 inchs short but w/ velcro no problem.    I priced building a cover/enclosure myself.   For this delivered price its well worth it.  If your looking for an enclosure for a 410 t boss this is it.  Comes in camo or black.  Will try and attach pictures and a link to amazon.  p.s. I have no ties to this company.  lol..... I just want others to know it will fit a t boss 410.  😉  https://www.amazon.com/gp/product/B00TPUBKH8/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1




×
×
  • Create New...