Quantcast
Jump to content


New guy from AZ


Guest

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Stan Morton
      My 2018 XG-850-SL starter died yesterday. The old part number from Kubota is E7153-11732 which has been superceed by part # EG881-63010. I am looking for an aftermarket starter because the Kubota retail price for the starter starts at $550 and upwards toward $850.  If anyone has gone down this road before and has found an aftermarket starter ~ please share with me. We own a ranch and this thing is used every single day and is sorely missed when it is down for maintenance.  Kind Regards, ~ Stan
    • By Alien10
      I have a Coleman Outfitter 550 purchased in January 2022 that runs and operates pretty well.  65 hours on it so far.   It is a work vehicle for my 10 hilly acres with two 1 acre woods and 5 acres of "lawn".  The rest is under a lake. 
      My parking brake does not seem to have any grip.  It worked when new but after a month or so, it is just almost useless.     I press the parking brake pedal hard until it stops. Still, it won't hold even on slight inclines.   I don't see the caliper move as I press the brake pedal down.  There seems to be plenty of pad left on it and the rotor is shiny as if it is rubbing a little when applied, but not enough to stop it from rolling. 
      Any thoughts on possible causes? 
       
    • By great8redsfan
      Okay folks. I have a low power issue. Been like this for a few years. Place I work at bought 3 and all have lost most of the pulling power.  They gave them away after local shop worked on one for 3 months and it had great power for about 1 month and then crap. They replaced throttle body, fuel injector, spark plug and IAC motor. Seat belt switches have wires cut and left open so no seat belt warning light anymore. It revs to 6k rpm in neutral but when put in gear and take off in low it just doesn’t seem to want to go anymore. Running 93 octane fuel with Stabil.  Any ideas greatly appreciated. I dont have a scan tool but no codes on dash. If held to floor it pops a little and runs almost 5K rpm but if I let off pedal about an inch it smoothed out and revs up to 6k rpm. 
    • By doncaron
      Hello everyone! 
      First of all I would like to thank you for the help with my timing problem, it was the chain. Now I’m looking for the part number for the wet clutch baring.  I’ve been looking for it but my side by side is a 2022 t-boss 550 and it’s not the same as a 2021. Can anyone help me please?
      thank you in advance again. 
       
    • By chuck92308
      I am throughly discussed with the 800sx.  It has a lot of suspension cracking and squeaking from the suspension/shocks.  Also been to the dealer 4 times for excessive drive clutch/belt squealing.  They have no clue and they have (supposedly) changed both clutches and drive belt. Anyone having any of these issues.
×
×
  • Create New...