Quantcast
Jump to content

New Here


DevilDog

Recommended Posts

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By BOYD
      I have a 2004 KUBOTA RTV 900 DIESEL and I need to replace both front cv axels.I have been online looking at them and there seems to be a lot of different manufactures to choose from. My question is who makes a good aftermarket set of cv axels for this KUBOTA. I have read horror stories of people buying the  cheap Chinese brand only to find out they don't fit or they don't last very long and fail again. I hate to have to spend over $200 a shaft to get OEM from KUBOTA when I'm sure there is a company out there who probably makes it for them or makes comparable to OEM. Thanks for your help.
    • By todd93
      Hi, all! I. I'm new to the board, hoping someone could help me out! I have a 2020 Hisun Sector 550C that I bought new in 2021. Today, I took some stuff next door to my parents. When I went to leave, I turned on the key, heard the solenoid click, but no lights, no guage activity, no fuel pump, and no starter. 
       
      The battery is good, I checked all the fuses, they are good. Not sure if the relays are good, or even what to look for there. Is it possible that it's maybe a wire? 
      I'm really stumped on this one! Any help would be deeply appreciated! Attached is a pic of the fuse box layout. 
       
      Thanks! 
      Todd 
    • By AlphaSerenity
      Hello,
      Before I invest $10k+ into a brand new UTV for the farm, I want to get my feet wet with a fixer upper and learn the mechanical side of things. I acquired a 2022 Hisun Axis 500 (Lowes-specific model) from an auction for $500. It has only 200 hours and 120 miles on the engine. It looks like the previous owner used it for ranch work and didn't drive it on trails, deep water/mud, or anything too crazy.
      While it runs and moves, it has some problems. It struggles to accelerate up any incline in high and low range and sometimes stalls when I let off of the throttle or change gears. When I apply throttle in neutral, it sounds like it is struggling for fuel/air and pops. When I decelerate, there is a grinding sound coming from the clutch, which I've read to be related to the one way bearing and is semi-common. The last thing I've observed is sometimes the speedometer display sometimes will show a much higher value for a few seconds after barely touching the throttle. Based on the documentation, if a problem is detected from the sensors, the instrument panel display should have an error code rendered on the screen in place of the time, but this isn't happening. Here is a video showing some of these issues (engine is exposed with console removed):
      https://www.youtube.com/watch?v=FFAkO5TaGps
       
      Here is another video of the clutches in action:
       
      I've done some research, but information on this specific unit and sister units is limited. There does seem to be transmission and clutch issues reported. I still need to check into the head gaskets. I don't have the equipment to test compression right now, but I do plan on ordering what is needed soon. I do have an order in place for some cables to read the diagnostics from the computer. There is a shop two hours away from me that works on Hisun products, but I am hoping the problem can be identified and is something within my ability to handle. Below is what I've already investigated.  I am leaning towards the primary clutch needing replacement right now.
      After getting it home and unloaded, I did the following maintenance/checks to it prior to operating it further:
      Changed the engine/clutch oil (and filter) and gear oils using manufacture recommended viscosity Changed the air filter and checked for cracks in the air intake flow. Verified good suction. Cleaned the throttle body Changed the spark plug and verified the gap was within spec (0.6-0.7mm) Changed the coil and coil wire Changed the fuel lines, fuel injector, and verified the fuel pump was outputting the correct initial prime pressure for ignition and continuous pressure after ignition. Also completely emptied the fuel tank and made sure octane 91+ fuel is being used per manufacturer specs. Ran seafoam through system too. Cleaned the spark arrester and verified no cracks or gaps in the exhaust flow Changed out the O2 sensor Checked all wired connections to ensure they were secured and no breaks were visible Checked the belt for tightness and for any signs of wear and tear Verified 4WD and the differential lock function as expected - still hesitates and struggles uphill Verified the fan gears in the shifter are not corroded and working as expected ECU was reset after replacing sensors and fuel-related parts  
       
      Thanks!
    • By lonerider98
      At the end of last year my Coleman UT 500 will not go into reverse. I can hold it over toward the reverse to move it nut it won't lock into reverse. Anyone have this problem? Winter is just about over and going to have to get this resolved. Thank You!
    • By Nypto
      I just bought a new Hisun 750 sxs. I drove one mile and it just died. No power at all. Battery is 12.8v. Found no blown fuses. No power to the panel, no nothing. Problem for me is I bought 160 acres near big bend. Trying to build a house. Got blown up in 'Nam . Can't walk much. Scared I'm way out and it fails again. I heard something  about a brake switch,  but I have no idea where it might be.
×
×
  • Create New...