Quantcast
Jump to content

over filled Gass tank


Jered

Recommended Posts

I started my trooper today prior to head out to the trails. Started with easy. Filled gas tank. Now won't start. Read not to over fill tank. Drained tank till half full. Now won't start.

what do I do or what possibly could have happened?

Link to comment
Share on other sites

Can anyone help? I think I overfilled my gas tank. Trooper was running great. Filled gas tank. Started but ran really rough for approx 1 min. Now won't start. Drained gas to half tank. Still won't start.

have I done any damage? If so what? How do I trouble shoot?

Link to comment
Share on other sites

sound like you got some bad gas, drain the tank and go get some new fuel some where other than where you got it before, flush the lines by pumping fuel into a can,, may need to pull the injector rail and clean it if you got fuel with sediment in it, the injector rail is dead ended, so if crap got in, it's stuck there, I drilled a hole in the end of mine and put a small fitting on it to allow the fuel to go back to the tank.

ps, drain the fuel into a glass bottle so you can see if it has crap in it.

Link to comment
Share on other sites

Guest Lenny

if you put a hole in the far end of the fuel rail, it has to go back to the regulator to maintain proper fuel pressure in the rail. Proper set up is for the fuel pump to feed into one end of the fuel rail with a line going from the other end to the regulator. The regulator wants to be after the fuel rail. Joyner has it set up wrong from the factory.

Link to comment
Share on other sites

this may not sound too technical...but have you confirmed that your fuel pump is running? second what year is your trooper?.they do have slightly different start up actions ....the older ones had a fuel pressure gauge at the left rear of the engine...that should show somewhere between 45-60 psi when the pump runs in pre start up mode (the new troopers use a different style regulator and no gauge) poor fuel..yup have run into that,but as far as setiment plugging thing up,hopefully your fuel filter would catch all/most of that...but plugged filters happen...finally when you say "wont start"..exactly what happens...you turn the key to the first position,wait for pump and fan (possibly) to run and the gauges to sweep...(you should then have fuel pressure at the gauge) when that is complete you turn to start position...cranks well but wont fire up?? try the same sequence with your foot slightly on the gas pedal...try again... I know this sounds simple,but sometimes its the simple things that keep one from starting ...just my 3 cents...Hardy

Link to comment
Share on other sites

  • 5 months later...

This happens a lot with the new Chery powered rails (Renli) that carbon canister is below the fuel level in the gas tank. Once that canister is saturated with fuel the engine wont start, it will start if you pull the vent line from the intake side but with out a filter you'll be pulling unfiltered air into the engine. Opt. 1: remove carbon canister plug all lines. (Tried this but engine would hard start and rough idle also not emissions compliant) Opt. 2: Vent intake manifold line to it's own filter and plug carbon canister (This works just keep it high and dry, still not emissions compliant.) Option 3: This a mechanic friend told me and after I was like duh, just put a longer hose from the gas tank to the carbon canister and put the high point higher than the high point in the gas tank. (This is emissions compliant) In cars and trucks the carbon canister is mounted above the fuel level in the tank and in Jeeps and SUV's it has an anti siphon valve to keep it from contaminating the canister. Also if the canister has been filled with fuel it takes a few hot days with all the lines off of it to dry it out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By malenurse13
      We just bought a used 2017 American Landmaster TW450. No hour meter that I can find, so not sure exactly how much it has been used. 
      The first 2 days we had it, the starter was a little sketchy, but it started after 2-3 tries. Sometimes when turning the key, we would hear a loud metal "clink" sound. Like the starter made contact, but didn't have enough power to turn. 
      THIS MORNING... Turning the key, we hear a single click sound. That's it. Even with a new battery, the starter is still doing the same thing. Both batteries (old and new) were reading 12.8 volts on volt meter. So I'm wondering what else could be going on? Any ideas on what to look for would be greatly appreciated...
      Thank you!
    • By nods
      Less than 40 miles can barely start. Dealer is working with Hisun on a number of other issues on this UTV. Can not get clear info on the meaning of these E codes this is getting. Anybody have some clear info for me?
    • By DJ Brusenski
      checked all the fuses and relays, I can jump start it with the key in the on position. it will not key start need some help, thanks
    • By Round
      Bought a Massimo 500 last night. Stopped and filled it up on the way home and I put the wrong gas in it. Is there a drain plug on the bottom of the tank that I can get to or will I have to siphon it out?
    • By Dave N.
      2020 Massimo Buck 400 - Won't start. Can hear the starter spinning, but motor never turns. Relay? Starter? Worked fine one day and not the next. Thanks for any help you can provide.
×
×
  • Create New...