Quantcast
Jump to content

toddstang

Hello

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • Every Kawasaki part imaginable!!

      Hi, all, I am here to say i have found an excellent source for kawasaki parts, It's run by  Eddie Babbit. It is called Kawasaki Partshouse. run by Babbits online, Muskegon Michigan. http://www.kawasakipartshouse.com/oemparts Just the other day i ordered piston rings, for my Mule 550, They got here and a Oil ring, and smaller ring were missing from the box, Kawasaki took responsibility for the "Accident" and  I had also contacted babbits, and they replied and they said" keep the old rings, order a new set and you just pay shipping" so i got $30 piston rings for 8.95!!!? Free shipping on orders over $50!!!  

      By Travis, in Kawasaki UTV SxS Forum

      • 2 replies
      • 1,549 views
    • West Virginia or Kentucky???

      There will be about 15 family members meeting up from all over and are looking for a good place to camp/ride. We were looking for somewhere to camp along the trails but if not then just somewhere with tons of trails with all levels of difficulties, creeks, scenery, etc. Any advice would be great, thank you!

      By Kirk0414, in UTV Ride Reports - Where to Ride

      • 2 replies
      • 2,853 views
    • Kawasaki mule submerged in water !!help.

      Any 1 with some good advice ,my Kawasaki 2017 mule side by side was submerged in water and now dead. What can i do ?  

      By Harry Thomas, in Kawasaki UTV SxS Forum

        
      • 9 replies
      • 991 views
    • Kawasaki 4010 (Gas) Revs/Puleses at top speed.

      Not sure I'm explaining that right. but,.. I'll start with some history.  I bought the 4x4 4010 mule with a bad motor.  I built the engine.  Bottom end up.  Fresh bearings, Pistons, etc.  Cranks up and runs with no issues.  However,.. doesn't seem to run faster than 20 mph and pulses at top speed like something is up with the governor.  It feels like its cutting back.  Climbing and pulling it seems to be fine,. It pulls hard and doesn't cut up.  But on the road flat out  Cuts back/Chugs/pulses/Revs.  Not sure where to start. Kinda tired of thinking about it. Any Ideas? Just a mention, I'm not trying to make it faster, just fixed.  25mph it good by me.  Hell,... for my purposes I'm fine with 20 mph as long as its' running properly.

      By brothaman, in Kawasaki UTV SxS Forum

      • 3 replies
      • 247 views
    • kaf620-e3 kawasaki mule side by side

      Hey all my mule runs great until it gets hot then  just quits. won't start back have to plug battery in to charge it up seems like the  battery doesn't recharge when it is running.

      By marypippin14, in UTV General Discussion

      • 5 replies
      • 198 views
×