Quantcast
Jump to content

hisun 800 intake backfire/no start


huey224

Recommended Posts

I am working on a friends hisun 800. he said whenever you transport it on a trailer it takes forever to start and he has to floor it to get it to start. he also said it wouldn't go over 30mph like it was being held back. I get it to my house try to start it and all im getting is backfire through intake. I checked spark it was good. I know its a no no but I sprayed a small shot of starting fluid in airbox to see if it would start and it backfired and lit the fluid on fire. currently I am wondering if the valves may be out of adjustment anybody have any suggestions or help would be greatly appreciated.

Link to comment
Share on other sites

An intake valve may be stuck open (most likely) or the valve timing may be off (less likely).  I would check the compression against the standard for this engine.  If compression is way low or near zero, an intake valve may be stuck open.  If compression is low in the neighborhood of 100 psi or so, the valve timing may be off.  Check the valve timing marks vs crankshaft position against the specs for this engine.

Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Hi sun 500
      hello everyone, i just joined this forum to try my luck, few days ago i bought an old (dont know exactly), 2011/14 hi sun 500cc ""carburated"",  was not running at the time, but i fell was a good deal and decided it to bring it home to play with it, this is the issue, i bought and installed a new carb, and pump, i repositioned the battery location and upgraded to a "car batt", reconnected the fuel lines and started it, but it only runs with the choke ON, i checked the bowl, it does have fuel,but for some reason wont inject it to run, i came across a video that say that ""the body small tank had to be connected for the cart to run" (was deleted when bought), sure enough i got it to run sporadically , but the so called ""small body tank'' often runs out of fuel and wont refill itself , i had to couple times do it manually, so how does that small tank works ?..what does it do?..and why if  bypass it , the cart wont start?....any help?..thanks so much!!!
    • By new owner
      no neutral light but engine turns over and wont start. whats wrong?
    • By johnpeter
      2012 polaris rzr 800 On Ebay
      https://www.ebay.com/itm/196255632017?

    • By Dave N.
      2020 Massimo Buck 400 - Won't start. Can hear the starter spinning, but motor never turns. Relay? Starter? Worked fine one day and not the next. Thanks for any help you can provide.
    • By azdesertdog
      A desert camp trip we took at Christmas in the desert
       
×
×
  • Create New...