Quantcast
Jump to content

2008 hisun rear axles


Recommended Posts

  • 3 months later...
  • 3 weeks later...
  • 10 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By OviV
      Has anyone found aftermarket side mirrors that work with angled bars on the 800sx other than the super expensive factory ones?
    • By EJW
      I have a 2011-12 Hisun Yard Sport HS700. Engine gets hot, but radiator does not. Changed the water pump, still the same. Service manual parts #15, 16, & 17 (pages 283-284) shows a "Save Temperture" #15, which looks like a thermostat. Service manual also parts #9, 10 & 11 shows it without a thermostat. Does this unit have a thermostat?
    • By res2fr
      Hello All,
       
       I am trying to find a Scanner that is works for a 2016 MSU500. I found the Tiny Scan TS301 that looks like a decent Scanner but so far have not been able to get confirmation that this works on and older model. It has been stated that it works on the 2019 and newer but not sure about older models. It appears that the ECM/ECU/EFI modules are likely interchangeable between a 2016 and the newer 2019 and on but not sure of the Scanner. I am waiting for feedback from Hisun on this issue right now.
       If this unit is not usable for my model year has anyone found and a Diagnostic Scanner for the older machines, one that works and is Affordable?
      Thanks for reading my post and any information that you may have to share,
      Robert
    • By Fib103182
      I have owned my 2015 Hisun HS700 Crew  for about 3 or 4 months now. I got it used and was supposed to run good but was not put all the back together from a stator upgrade due to previous owner said he was going to out a stereo system on it. Anyway I have worked it much more than I have rode it. I seem to work on it 2 days and ride it for a hour. Me, my wife, and 2 kids (10 and 18) enjoy it but the engine compartment gets so hot. I've replaced the water pump and burped the cooling system and any other thing I could think of to bleed the air out and think its good with no air and water circulating. Fan seems to run fine and be on about all the time. Changed the coolant twice and oil 3 times. I noticed the engine really has nowhere for heat to go because heat rises and no air flow at all. Has anyone had any experience in this area? Any DIY tricks or any advice in removing the heat out of the engine compartment and getting it to a tolerable temperature. Im about to sell it if I can't figure something out and go waste money on a big name brand but I won't have red legs and arm from engine heat burning me and my wife. They machine never acts like its to hot or anything but it feels like it is. Thanks in advance for any and all help. 
    • eManualOnline
    • By Quade
      This is my first UTV and it ran great the first 500 miles. Then it slowly got harder and harder to start. Now I have to keep giving it gas when I first start it for about 1 minute until it will idle by itself. This past weekend I took it on the trail and it died 15 minutes into the ride and lost all spark. I got towed home and tried to see if I had spark the next morning which I did and it started but died 10 minutes later. Anyone have any ideas what I should do or check? Anything would help thank you!

×
×
  • Create New...