Quantcast
Jump to content

Charles Newton Jr.

2008 hisun rear axles

Recommended Posts



Did they fit?  I have a 2010 that is in need of rear axles and you are right the price is about half of the HISUN 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Neil Wilson
      I just bought a 2008 Trooper T2 not knowing much about them. On this one the owner said the horn doesn't work, the winch never did work and during inspection the rear brake lights didn't work. He said he replaced the rear light pods recently and the brake lights worked before. He said the fuse module is corroded so he bypassed it and rigged up his own switches for the fuel pump and radiator fan. I see in the wiring diagram the horn and rear brake lights are on the same circuit. Now I am worried the problem is in the wiring harness.
      I have the wiring diagram from the online manual but I can't make any sense of it. I see lots of posts about wiring issues and I am feeling a bit overwhelmed with all the issues I see with these machines and am regretting buying it.
      For now my main concern is to get the brake lights working so I can drive it to some nearby trails. I would appreciate any advice on how to go about diagnosing the problem or workarounds. Also if there is a better wiring diagram out there that might help. I would consider hiring someone local to diagnose it so any recommendations are welcome.
      TIA.
    • By Andreas Ahrens
      Hi All,
      Our Hisun is not making any power. Once you start to climb RPM's it almost sounds like the timing is out, it sputters and farts and doesn't want to climb RPM's at all. It starts fine though.
      I checked and set the valves, they were a bit tight but not bad. The spark plug is very black. The exhaust valves are a real nightmare to get to fyi.
      On the last service the dealer put the wrong plug in, so I'm switching that back to stock as soon as we get one. I'm also thinking the air filter should be checked/cleaned. 
      Any other things to check?
    • By Farm man
      I have a hisun 700 I went out to start it one morning and it made a clunk then nothing I am  mechanical inclined so I start trying to figure things out.  I narrowed it down to starter.  I changed it out with a brand new starter it made a grinding sound then nothing please advise me as I’m a old points and spark plug kind of guy not much experience with utv point me in the right direction don’t want to start tearing things down that don’t help??
    • By Joel Goldsney
      Wasn't sure exactly how to title this thread as I have a few issues with my newly acquired hisun UTV. Hopefully going to consolidate all the issues in one thread. 
      I purchased from a guy who  had rebuilt the engine  replaced the fuel pump as well as re-done the front end. He had the unit running and driving when it quit and would not start. He got frustrated and decided no more projects and sold it to me.  Unit is in excellent condition physically.....hardly any scratches on the plastics. All in all its a good unit with the following issues/symptoms
      1) Mis fire and stalling out when revved
      Well as you can see by the title of the first issue I managed to get the unit running.  Seems that the battery was very weak. I charged the unit and it fired up fine.  The engine seems to stutter and misfire when revved and once the unit warms up it stalls out. I think it's a fuel issue as if I give it a shot of ether it starts back up.  
      Additional Note: Revving engine in Neutral  seems to cause indication to flicker and occasionally the reverse light comes on  which seems to kick in the reverse rev limiter. Have also hade this happen when driving around. Reverse Light flickers and revs get cut. 
      2) Fuel line configuration.
      When he replaced the fuel pump he got creative with the tubing and removed the "small fuel tank" 
      (See pictures)
      Not sure  what the purpose of this tank is but would love some pictures of a stock set up so I can  put everything back together correct.

       
      3) Issues engaging in gear
      The unit seems to have issues going in to gear...I will move the shifter in place  but the gear won't engage and the lights don't indicate correct. It takes a few tries to engage and sometimes it grinds a bit 
      4) Rack and pinion slipping
      This problem is probably a simple replacement fix...when turning to the right with the vehicle not moving the steering just slipps and turns without turning the tire. I believe I just need to replace the rack and pinion but if there is something else please let me know.
      Any insight or tips on resolving any of these issues would be much appreciated.
    • By Chad Rice
      HELP - my wife and i just bought a 2013 joyner trooper 1100 and we rode for 2 evenings with no problems. Went to ride last night and all of a sudden it acted like something was catching up and it didn't want to move easily. Whatever it was must've broke and now it moves with no problem but is making a rubbing/grinding noise somewhere in the backend. Could it be wheel bearing, differential, or something in cv shaft. Any info or similar experiences is appreciated. 


×
×
  • Create New...