Quantcast
Jump to content

Massimo 500 secondary spring


Swampdonkey
 Share

Recommended Posts

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By Ric Silveira
      Got me a New Coleman Outfitter 2021 400
      and joining here to hopefully learn lots about it.
      I understand it's not top of the line but couldn't offord other. I'll be using it for riding around the neighborhood and light off reading here in Southwest Florida and not planing on beating it just some fun with my wife
    • By Kristen
      Can anyone help me figure out a part number for a replacement clutch. I have an older bobcat 2200 gas UTV and I have called local UTV/ATV suppliers and they do not have what I need. I was told by one that it would be a polaris clutch but I can not find any information as to which one to order online. 
    • By JakeK
      First time poster - new member. Most issues between my pioneer 700 and Challenger 700 I’ve been able to fix without issue. This problem is a different story. Have a 2016 Challenger 700 that overheated due to cooling fan not coming on. Changed both temp sensors on thermostat housing as well as radiator temp sensor. (Being that unit overheated I teplaced to be safe) Put power to fan to verify operation - works great. Checked all fuses, connections ect. No issues found. Verified coolant level and air bled out - all good. Using a temp gun I Can see temps climb to 210 at thermostat housing and 195 at rad at sensor location and fan won’t turn on. Any help on where to check or any wiring schematics for this unit ?
    • By Strongsteven
      My 2014 mule has all 4 25x11-10’s. Mule has 2” lift kit installed. I need new tires. I found a fantastic new set of 2 25x11-10 and 2 25x9-10.  Will the 9” work for the front?  If so whats pro’s con’s of not having all 4 the same. I have the oem 10 “ rims. 
    • eManualOnline
    • By IslandHopper
      Can anyone tell me if their MSU 500 or 700 fuel pump and injector cycle when you turn the key on? This will help me rule out the Crank Position Sensor as a problem.
      I just bought this non-running and the service manual is not much help.
      Thanks

×
×
  • Create New...