Quantcast
Jump to content


2017 Cub Cadet Challenger 550


Joe

Recommended Posts

ran it saturday and noticed when going in reverse engine revs up but utv doesnt seem to want to move fast enough in reverse... when in forward high or low runs fine! the 550 has 500 miles and also a new belt before we purchased utv used...its belt driven so i believe there is no adjustment for tension could belt be glazed? doesnt look to easy to get to or see

Thanks Joe

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By mac66
      Just bought a used UTV, my first SxS.  It is extremely LOUD!   Was thinking of wearing shooting ear muffs to muffle the noise but then my passenger( wife) and I couldn't hear each other over the shouting we have to do now.... On the other hand we sometime ride with my brother and his wife and would like to be able to communicate. We throught about FRS and/or GMRS radios (we are licensed for GMRS) but we'd have to wear earphones under our ear muffs. My state doesn't require helmets to ride UTVs.
      I suppose if everyone has a cheap FRS/gmrs bubble pack radio with a ear phone we could all talk to one another. Just wear an ear plug in the other ear or ear muffs.
      Looking for suggestions.
    • By kgs
      Got a hisun sector 550 2019 that's got 5900 Miles on it, this year it started to getting hard to start in morning, once I get it started it works good the rest of the day. But to start it in the morning I got to hold the gas pedal to the floor and it will fire up. I replaced the fuel injector but didn't help it. So I just ordered a new air filter and 02 sensor and a maf sensor to put on it to see if this will fix it. Anyone else had this problem. I'm hoping the parts I ordered will fix it. I also bought a new battery to put in it also.
    • By Blackwellok
      Hi from oklahoma
      Does anyone else own  a coleman unit. ?
       
    • By Alien10
      I have a Coleman Outfitter 550 purchased in January 2022 that runs and operates pretty well.  65 hours on it so far.   It is a work vehicle for my 10 hilly acres with two 1 acre woods and 5 acres of "lawn".  The rest is under a lake. 
      My parking brake does not seem to have any grip.  It worked when new but after a month or so, it is just almost useless.     I press the parking brake pedal hard until it stops. Still, it won't hold even on slight inclines.   I don't see the caliper move as I press the brake pedal down.  There seems to be plenty of pad left on it and the rotor is shiny as if it is rubbing a little when applied, but not enough to stop it from rolling. 
      Any thoughts on possible causes? 
       
    • By Mark T
      MY 400 is gutless. I would like to know if I can upgrade to a larger engine ?
×
×
  • Create New...