Jump to content

Q-Link Fuel injector not working


Recommended Posts

I have a Q-Link (Rhino clone) and the fuel injector won't open up and spray. The fuel pump is brand-new and kicks on and primes to the injector but nothing comes out.

I've cleaned and dielectric greased the electrical plug and the ECU plugs but no change. not sure where to go from here. Any help?




Link to comment
Share on other sites

I'm curious, how did you check the injector to verify it wasn't flowing? 

First thing I would do it stick an ohmmeter on it and look at the resistance across the injector.  I would imagine somewhere between 5-50 ohms.  Then I'd check voltage coming to it during start up to see the "pulses".  If I've got voltage, but no squirt-squirt, bad injector.  If the injector is pulsing but not squirting, its clogged.  Either way, new injector.  

  • Like 2
Link to comment
Share on other sites

It did click and was pressurized but nothing came out. The fuel pump is new. 
I bought this for $500. It’s been sitting for like 6 years and so many many dummy’s have messed with it that things were out of sorts. I believe I’ve got ever in order again. It only has 23 miles on it. 
I ordered a new injector. Should be here in a couple days. 

Link to comment
Share on other sites

  • Alex changed the title to Q-Link Fuel injector not working

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Wolfpaak
      Pink Floyd quote/reference.
      i am looking for a starter for my 2004 800 Renegade and apparently the place I dealt with before is no longer in business. Any help?
      Thanks in advance,

    • By CYJSP2009
      Dear Friends, 
      2022 Brand new Joyner CV Axles and CV  Joint rebuild kits are comming 
      1.  S650. ---Joyner 650 Commando Rear
      2. TR1100. --- Joyner Trooper Front 
      3. TR1100. --- Joyner Trooper Rear
      4. D650. --- Joyner 650 Sand Spider Rear Left 
      5. D650. Joyner 650 Sand Spider Rear Right 
      6. SV800. --- Joyner 800 Viper, SV1100 Drive shaft Left
      7.  14274 --- 650 ider rear left, rear right, 800 MV; 800Viper, SV1100 Drive shaft rear left and rear right outer cv joint rebuild kit
      8. 15803  ---  650 Sand Spider rear left, rear right, 800 MV; 800Viper, SV1100 Drive shaft rear left and rear right outer cv joint rebuild kit
      Attached are the part photos for reference. 
      Above parts are now on the way to USA, will be ready for inland delivery in middle of July. 
      Price: CV Axle: USD250/ Piece;  CV Joint kit (without grease): USD110  send to door. 
      There will be special discount availabe for deals completed within July 2022.  
      Buy 1 piece: Get 5% discount, 
      Buy 2 pieces: get 10% discount.
      Buy 3 pieces: get 15% discount, 
      Buy 4 and more than 4 pieces: get 20% discount. 
      Please kindly note Qty for each part is not big  and it is hard to forcast when there will be next offer for these kind of products unless there is sufficient confirmed order qty for productioin arrangement. 
      Payment method: Payoneer payment link ( can pay through bank account or credit card) or Paypal ( [email protected]) .  Payment commission paid by the buyer. 
      Interested parties, please contact [email protected]
      Good Luck
      Casey / Leaf Asia

    • By Kenbaz
      Well, the subject says it all!  After the motor stopped, I went out and bought gas and filled the tank.  Tried to start and it just cranked - no fire. I assumed I had spark, because nothing changed there. I pulled the plug and could not smell gas. The plug was dry. Put it back in and tried to flood it by piumping the pedal, but it was still dry when I  took out again. 
         The gas gage red fuel lights didn't seem to recognize that I filled the tank (see previous fuel Haugen posts).  Disconnected and reconnected the negative battery terminal hoping it would reset any interlocks that might be set. Now the ignition panel will not light up when ignition turned to "On".  Things are getting worse instead of better!  Have the fuse panel open, will check fuses tomorrow. Can anyone help me get back on track?  No shop here in Tucson will work on it!  Nice unit. But you're on your own for maintenence. Thanks for any help!
    • By Cody Brown
      Not sure how better to describe it other than no lights, head lights, dash lights, no cycling of fuel pump when the key is turned, no starter activity, etc.  checked all fuses in the fuse box under the driver seat (anyone know of any other fuses I might have missed?).  Hooked starter up directly to the battery for a split second and it cycled fine.  Same with the radiator fan.  This machine was running fine during a ride, and my son hit a bump, it died, and never came back.
    • Get More For Your Device
    • By Jangalang
      2015 900s some fuses do not energize when switch is turned on. Just went thru the charging system failure. Have ran buggy since charging failure repair.
  • Similar Tagged Content

  • Gallery Images

  • Create New...