Quantcast
Jump to content

Nazary Vasilchenko

2016 Cub Cadet Challenger Crew 750 Help Needed

Recommended Posts

Hi everyone, I’m new to the forum and was looking to get some help from anyone that has the same UTV as mine. 

So I just picked up a 2016 Cub cadet challenger crew with eps. It’s needs work, the guy that I bought it from completely took the machine apart due to needing an engine rebuild, but he also took off some spare parts to keep for his other machine. So basically I’m missing a few electronics, I think I’m missing a relay box and ecu but I’m not sure. I’ve looked everywhere on the internet for some pictures under the hood and can’t find anything. I’ve found part schematics but some of the pictures are not clear.

Can someone please open up their hood and post a few pictures of that area? There are a few bolt locations but I can’t find what goes there. It would really help me out. 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Chris B Legge
      I have checked that the fan operates if you bypass it, I have checked the fuses, I have checked the relays but the fan does not come on and overheats. Has anyone had this experience. HELP!!
       
      Chris Legge
    • By Troy
      I purchased my 2018 Cub Cadet 750 Challenger new in July 2019 and it will not go into 4 wheel drive.  Has this ever happened to anyone or do you have any idea as to what could be wrong?
    • By PierceIt
      Hi everyone - I was driving my 2017 Cub Cadet Challenger 750 EPS today on the ranch when it dies on me. It started right up - and then as i was driving after about 50 feet the engine just turned off. It was running perfect before it cut out on me. No alarms, no weird sounds or smells. It just turned off. 
      When I turn the ignition key, the starter cranks away and the battery and starter turns fast and strong - but the engine doesn't start.
      I've confirmed gas flow to the carb - that the fuel filters are clean and clear. I've replaced the spark plug with a brand new one. I checked every fuse with a meter. I have confirmed air filters and airflow are good. 
      But the darn thing cranks away without the engine even making a sputter or even attempting to fire.
      Is there a kill switch somewhere that could have been tripped? I checked the seatbelt sensor, the brake sensor, and parking gear sensor - all are working and i'm in Park, pressing down on the brake, and have the seatbelt latched when i try to start. but - nada!
      It acts like it isn't getting a spark. but like i said i put in a new spark plug. I have a feeling there is a sensor or an electrical kill switch somewhere that tripped. 
      open to any ideas.
      thanks all
      Pierce
    • By Billbo
      The main key fuse (25A) burns out as soon as a replace it (even with key in the off position) and even with ignition disconnected.  Any ideas on where to start looking to determine where the short is?  Or does anyone know where I can find a wiring diagram? 
       
      Model 37bm467d710
      Serial 1d042z50007
  • Similar Tagged Content

    • By PierceIt
      Hi everyone - I was driving my 2017 Cub Cadet Challenger 750 EPS today on the ranch when it dies on me. It started right up - and then as i was driving after about 50 feet the engine just turned off. It was running perfect before it cut out on me. No alarms, no weird sounds or smells. It just turned off. 
      When I turn the ignition key, the starter cranks away and the battery and starter turns fast and strong - but the engine doesn't start.
      I've confirmed gas flow to the carb - that the fuel filters are clean and clear. I've replaced the spark plug with a brand new one. I checked every fuse with a meter. I have confirmed air filters and airflow are good. 
      But the darn thing cranks away without the engine even making a sputter or even attempting to fire.
      Is there a kill switch somewhere that could have been tripped? I checked the seatbelt sensor, the brake sensor, and parking gear sensor - all are working and i'm in Park, pressing down on the brake, and have the seatbelt latched when i try to start. but - nada!
      It acts like it isn't getting a spark. but like i said i put in a new spark plug. I have a feeling there is a sensor or an electrical kill switch somewhere that tripped. 
      open to any ideas.
      thanks all
      Pierce
    • By PierceIt
      Hi everyone - Since Hisun makes Cub Cadet Challengers i am posting this here too as well as the cub cadet forum in hopes of reaching someone who can help me. 
      I was driving my 2017 Cub Cadet Challenger 750 EPS today on the ranch when it dies on me. It started right up - and then as i was driving after about 50 feet the engine just turned off. It was running perfect before it cut out on me. No alarms, no weird sounds or smells. It just turned off.  When I turn the ignition key, the starter cranks away and the battery and starter turns fast and strong - but the engine doesn't start. I've confirmed gas flow to the carb - that the fuel filters are clean and clear. I've replaced the spark plug with a brand new one. I checked every fuse with a meter. I have confirmed air filters and airflow are good.  But the darn thing cranks away without the engine even making a sputter or even attempting to fire. Is there a kill switch somewhere that could have been tripped? I checked the seatbelt sensor, the brake sensor, and parking gear sensor - all are working and i'm in Park, pressing down on the brake, and have the seatbelt latched when i try to start. but - nada! It acts like it isn't getting a spark. but like i said i put in a new spark plug. I have a feeling there is a sensor or an electrical kill switch somewhere that tripped.  open to any ideas.
      thanks all,
      Pierce
       
    • By Cub owner
      Ok trying again... I have 2018 cub cadet 750. Having clutch issues. Has anyone bought a upgrade for them and where did you get them and about how much. Thanks for any help given. From what i have looked over on here. Lots of nice helpful people 


×
×
  • Create New...