Quantcast
Jump to content

2005 massimo ITV 700 fuel system


Recommended Posts

This is a carb model not EFI it was in pieces when I got it. I got it running by replacing the fuel pump had to bypass this little reservoir thing I can’t find how it goes back in please help. Machine runs good but I have fuel coming out of the drain on the carb. This is a pic of the reservoir thing thanks

0D5841B5-5D04-4C90-8FB3-207EC6F80D4F.jpeg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Nathon S.
      I have a Bennche 700 EFI Bighorn. I’ve recently been unable to get it to start. After a little troubleshooting I realized my fuel pump was not pumping fuel. This weekend I emptied the gas and replaced it with new. I replaced the fuel pump, fuel filter and fuel injector. I also replaced the battery, spark plug and made sure all my fuses and relays were good. I have confirmed that the float on the fuel pump is not obstructed. The UTV is about 12 years old and has less than 100 hours on it. It has not run in over a year.  Not sure whats going on?!? After doing a little reading I'm leaning towards it being an issue with the ECU or perhaps a faulty wire in the wiring harness. Anyone have any ideas on where to start looking or what I could be dealing with? Any help is appreciated, thanks in advance!
    • By Hi sun 500
      hello everyone, i just joined this forum to try my luck, few days ago i bought an old (dont know exactly), 2011/14 hi sun 500cc ""carburated"",  was not running at the time, but i fell was a good deal and decided it to bring it home to play with it, this is the issue, i bought and installed a new carb, and pump, i repositioned the battery location and upgraded to a "car batt", reconnected the fuel lines and started it, but it only runs with the choke ON, i checked the bowl, it does have fuel,but for some reason wont inject it to run, i came across a video that say that ""the body small tank had to be connected for the cart to run" (was deleted when bought), sure enough i got it to run sporadically , but the so called ""small body tank'' often runs out of fuel and wont refill itself , i had to couple times do it manually, so how does that small tank works ?..what does it do?..and why if  bypass it , the cart wont start?....any help?..thanks so much!!!
    • By Richard shepard
      I have a 2021 colman 400utv engine will start and idle, as soon as you hit throttle to move engine dies and will only start when you throttle it, let off throttle it dies, I replaced the injector and plug still the same, anyone have any other ideas
    • By weasel
      starts up you have keep rpms up for 5 minutes till it warms up then runs fine. But if it stalls wont start unless you unplug fuel pump and hold it to the floor till it starts then plug pump back in and run it till it warms up then it is fine all day.
    • By Round
      Bought a Massimo 500 last night. Stopped and filled it up on the way home and I put the wrong gas in it. Is there a drain plug on the bottom of the tank that I can get to or will I have to siphon it out?
×
×
  • Create New...