Quantcast
Jump to content

Wheels For KAF 400 sx 4x4 xc


Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By buckrub
      Hey guys! Newbie here. I'm an old man who's better with plowing a mule (4-legged kind) than these newfangled beasts. I, and a friend of mine, just bought new Coleman sxs and are having to finish the assembly. I've been reading on this site and I'm falling on the mercy of you experts. The only way I'm an expert is that an "ex" is a has been, and a spurt is a drip under pressure. LOL First off, the 2 buggies have no ignition switches. They seem to mount on the dash, not the opening in the steering wheel shaft cover, so we ordered new ones that are supposed to fit. They are 8 inches long, and have a 4-wired white plugin which is slightly rectangled when looking at the end of the plug. The trouble is there's nothing to plug into. There is a three-wire grey plug close enough to reach the four-wire plug, but of course, they are not compatible. 
      Secondly, the blinker, light, ect. unit on steering wheel just spins around when touched. I see no way in heaven or earth to secure it. I've looked at a diagram on the Powersports site, but can't detect how it mounted. Fellows I'd be so grateful for any help with this. Me and my mule will even plow your garden for free, for your help. LOL 
       
    • By moonrover
      Mine is overheated/burned/melt at connection with its wire connector, parts are ordered to replace both them.  This seems to be a common issue, and some of you already replaced it. I right now just connect the wires, so the fan runs  all the time whenever the initiation is on, but it's better let fan runs as needed with a working temperature sensor/switch. 
      Question: Does some coolant come out by removing the switch/sensor from radiator?  Or, is the threaded hole all the way inside radiator?   If the answer is yes,  I want to drain or extract  some coolant to make its level below the sensor before replacing it, so I don't make a mess with coolant spilled out 
      Thank you.  
    • By KMart
      I have a Massimo 400 Buck that overheats and the antifreeze blows out of the motor everywhere! I don’t have to be doing anything but just driving through the field.  It only has 26 miles on it.  I don’t think the fan is turning to cool the motor.  Any ideas how to fix this?
    • By Richard shepard
      I have a 2021 colman 400utv engine will start and idle, as soon as you hit throttle to move engine dies and will only start when you throttle it, let off throttle it dies, I replaced the injector and plug still the same, anyone have any other ideas
    • By Robert B
      Going down a 20 deg hill engine is holding UTV back. Then something releases like going into Neutral and makes a loud clacking noise. Have to use brake to slow UTV down. Then once level it shifts back into gear. Have done shift extension does not pop out of gear.
×
×
  • Create New...