Quantcast
Jump to content

johnpeter

2015 Polaris RZR XP4 1000 4 Seater UTV SXS with 22” Forgiato Wheels

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By johnpeter
      2015 Polaris Razor 900 4 seater On Ebay
      https://www.ebay.com/itm/2015-Polaris-Razor-900-4-seater/293968603248?

    • By ANIL SEDALI
      Hi friends, I have a new utv Hisun 700. My problem is idle adjustment.  How is idle adjustment done? While my engine is idling 2500- 2700 rpm. I need idling adjustment 1500 rpm. Where I am, there is no master who understands this tool. How do you do the idle setting? Can you help me? Hello everyone. Thank you.
    • By johnpeter
      2020 Polaris Razor 1000 Turbo customized On Ebay
      https://www.ebay.com/itm/2020-Polaris-Razor-1000-Turbo/203254252483?

    • By ANIL SEDALI
      Hi friends. I'm Anıl. I live in Turkey. I have a Hisun 700 UTV 2015 Models. My problem is : 
      inability to change gear after the engine has started. Before the engine starts, it can shift into all gears; but after running, I cannot change gear. At about 3000 km. Fuel injection model. Can anyone help on this topic? Thank you!
    • By Chris Miller
      Good Morning Folks..Happy New Year, I have been having some intermittent issues with my 2015 American Landmaster LM500 not going into neutral. Seems if I shut the engine off it would pop into neutral. Yesterday I was splitting firewood with a 500 pound log splitter that I pushed to my wood area up a slight grade. I was not able to get it into neutral which I assumed was due to the pressure of the weight of the splitter pushing back. after I finished splitting wood, I used the weight of the splitter to roll back down the hill to my driveway. I unhooked the splitter but still could not get it to go into neutral or start. I dragged it back into my barn with my mower as I don't leave anything outside over night. I am at a loss what to check to try to fix this. I use my UTV (Eustas) every day that I am at my place where I keep it and will be lost without it. Thoughts? 
  • Similar Tagged Content



×
×
  • Create New...