Jump to content

2015 Massimo MSU 800 help

Don W

Recommended Posts

Has been basically bullet proof 7 yrs.  Now won't start. Turns over fine. Pulled and changed plug...was dry, seems to have no fire. Also no fuel. I also do not hear the fuel pump come up to pressure when I turn key to on position.  Unfortunatley lost manual. On line manual says fuses are beside the battery under the hood. This MSU does not have a hood and the battery is under the drivers seat/....no fuses. Can someone PLEASE tell me where the fuse box may be?


Link to comment
Share on other sites

  • Alex changed the title to 2015 Massimo MSU 800 help
Shop battery chargers at ChromeBattery.com
2 hours ago, Joe Breaux said:

if you dont hear the pump pressure up, thats likely the problem.. after 7 years.. 

For sure!! That and the fact there's no fire to the plug. This is whyIneeded the manual in order to find the fuse box. I know the pump isn't running but need to find out why....

Link to comment
Share on other sites

Buddy , unfortunately, we both made the same mistake.  we bought a Massimo .. no one warned me, I dont know if you were warned , but if you ever visited this forum , it would be hard to miss the massive dissatisfaction . ALL of us have had problems with the machines and pathetic service and non-existent warranty from Massimo.. I ll be happy to go look at mine and see if theres any fuse anywhere on it and let you know. 

Link to comment
Share on other sites

Sorry you don't like yours, like I said 7 yrs mine has been bullet proof. I've used it hard, really haven't done the maintenance I should of. Like ALL atv the brakes are only half what they should be at best. I lost my manual (can't blame Hisun for that) Simply having trouble finding fuse box which I believe I now know where it is via you tube. I can buy any part thru scaotosports online. Hisun make several makes af ATV. If ever I buy another thats what it will be. Several thousand less than the big boy models and better equipped, I.E. standard with roof, full windshield and winch. Most makes all that is optional....another couple grand. Can't say anything about warranty, I've never had ANYTHING break that would be covered by anyones warranty.

Link to comment
Share on other sites

Found the fuse box, thanks, no blown fuse. Connections appear good, but that wouldn’t explain no spark anyhow.  There are five fuses three spare fuses and five mini relays that are unrepairable wish I knew how to test them anyhow there are other things to test thank you

Link to comment
Share on other sites

  • 3 months later...

O'k since last post I let it set, went on a vacation, got busy with other things.  I tried everyones suggestions..no luck. Also it DOES have a fuse/relay box under the drivers seat. You remove the seat AND the bolt down panel under the seat and the box (its small) is bolted to the frame. It's maybe 4" x 2.5" and 3-4 inch thick max! Front and back is screwed down for moisture protection. No fuses blown. there are 5 little relays soldered in. 

Tested the connector at pump, there are 12volts to the pump with switch on and something like 4-5 volts in the 4 pole connector to the fuel gauge (it works). There is no ground to the pump. Pump is supposed to cycle 2-3 seconds when you turn key on...I traced the ground wire over the engine, opening the harness all the way to the fuse/relay panel thru 2-3 plug connectors with the wire changing colors 3 times!! There are no branches in the wire. I have continuity all the way from the fuel pump to a relay in the box. Removed fuel pump and it runs on the bench. Re-installed pump, attached jumper wire from ground to frame and it runs. So ground IS the problem but why??  Also still no spark to EITHER plug.

Replaced the fuse/relay box with new...still no fuel ground or spark. Oh, new battery as old one was bad. Thinking new ECU? Its a DOLPHI MT05, used on over 50 UTV/moptorcycles........FINALLY a question. As this ECU is used on many different makes/models does it have to be programed/flashed for my specific machine? If so any suggestions would be appreciated.


Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Weber
      Hello.  Can anyone provide location of fuel pump relay switch.  According to the tech at Massimo it is not in the fuse/relay switch box but mounted near the fuel pump, but I am not seeing it.  Pics would be appreciated also and thank you in advance.
    • By NewtoUTV
      We just purchased the Coleman UT400, I put 5 gallons of fuel in the tank and the fuel indicator still reads "empty".  After looking around the fuel tank, I found a tube that is only connected at one end, maybe this is the issue?  I have been looking for a more comprehensive manual that may show how this tube should be connected, no luck.  Looking for help on this issue/issues.  Thank you.

    • By malenurse13
      We just bought a used 2017 American Landmaster TW450. No hour meter that I can find, so not sure exactly how much it has been used. 
      The first 2 days we had it, the starter was a little sketchy, but it started after 2-3 tries. Sometimes when turning the key, we would hear a loud metal "clink" sound. Like the starter made contact, but didn't have enough power to turn. 
      THIS MORNING... Turning the key, we hear a single click sound. That's it. Even with a new battery, the starter is still doing the same thing. Both batteries (old and new) were reading 12.8 volts on volt meter. So I'm wondering what else could be going on? Any ideas on what to look for would be greatly appreciated...
      Thank you!
    • By Blaine
      Was wondering if anyone knows how to check a waterpump on a 2013 arctic cat prowler 1000 XTZ My cat overheated  and I was not working it that hard Have checked for antifreeze in oil in case it was a head gasket but its clean 
      Next step will be to check pump and thermostat I know how to check thermostat  but clueless on checking pump I did refill rad and the started machine with cap off and coolant level did not change
    • By Greg Kilgore
      I installed an electric coolant temp gauge and volt gauge today. The oil pressure gauge I ordered had a bad sending unit. So once the replacement arrives. I'll add that install to the post. The I used a 22mm temp radiator adapter.

      1/8 " NTP x 1/8 NTP adapter.

      And an electric temp gauge.

      Had to take a drill and drill bit to enlarge the 1/8 NTP adapter to allow the temp sending unit to pass thru. Another user on the forum enlarged the 1/8 NTP hole in the 22mm radiator to 1/4 NTP and used a 1/4 NTP x 1/8 NTP reducer. Either way would work. Both has it challenges. And both accomplished the same thing. To get the sending unit just barely in the coolant. If you just put the sending unit in. IMO it just blocks too much of the coolant flow.
      I didn't get a pic of how far the sending unit protrudes into the rad adapter. But it wasn't a lot. And also since it an electric gauge the sending unit needed to be grounded. But since there wasn't a place on the temp radiator adapter. I used a clamp to secure a ground/negative wires to the temp sending unit. The gauge wiring was simple. The gauge's wiring harness had a red, green, and black wire. Red goes to a positive. Black to a negative. Green to the sending unit. Since I had some 18 AGW speaker wire. I used that to run to the sending unit. Red to green, black to black. 
      Then another piece of the speaker wire from the gauge to power source. I tapped into the 12V power outlet on the dash. (Just as I did for the overhead fan.)
      Then used a 2" hole saw to cut into the plastic above what I'd call the radio door.

      The gauge goes to about 174° F then the radiator fan kicks on. Cools down to about 150° F and kicks off. Now the lowest the temp gauge will read is 104° when you first start the machine. That is the nature of the gauge. Even says so on the web page. So I'll just have to live with it.
      The voltage gauge
      Was simple to install. Just a positive and negative wire to connect.  Tapped into the 12V power outlet on the dash.
  • Similar Tagged Content

  • Gallery Images

  • Create New...