Jump to content

Charging issue with a Sector E1

Go to solution Solved by Cougsfan,

Recommended Posts

Yesterday I took my E1 out and everything was fine.  I plugged it in when I got back like I normally do.  When I went to take it out I noticed the battery had not charged overnight.  I reconnected the charger and watched its behavior.  When first plugged in the yellow light on the charge indicator panel is on for a couple of seconds, then it starts to flash the green charge light as usual.  After about a second I hear a relay click and the green light goes out.  About 2 seconds it starts the charge light flashing, then quits like before.  It does this cycle 4 times and then the yellow light starts blinking.  There is no code displayed on the main instrument panel.  Any help would be appreciated.  My dealer said to call Hisun, they've never worked on one.  Hisun told me to read my owners manual.  I found no reference to the charge indicator panel in the manual.

Link to comment
Share on other sites

Thanks for the reply and the pdf file.  I found something similar on the Delta-Q website.  Since I posted originally, I have done a good bit of research on the charger.  I discovered the status display on the charger.  The charge indicator green light is not on.  The only light is the blue AC power light connected indicator.  I have not had the chance to try to read the error code display.  When I was looking at it, there was no characters being displayed.  How to you trigger the display to output the error code?  Should it continuously cycle through the code when plugged in, or dose it just do it once when the AC power is first connected?

Link to comment
Share on other sites

Is there a code displayed on the charger itself? If you look in over the front wheel from the driver's side, you can see the charger's own display cycling. It should show up an error code there. It's a Delta-Q ICL series charger, if memory serves (and they've not changed it since mine was built).

Link to comment
Share on other sites

Not sure what happened there! Didn't mean to repost my earlier reply.


I'm no expert on the charger, but as far as I know, the two digit readout lights up when it is on, either with a status or a rolling error code. If it's not doing either, then there's something else wrong. I read a thread a while back about road crud getting into the power connector, so it might be that or a corroded connection. You need to be very careful and isolate the battery pack before poking around though. UK spec E1s have a big red circuit breaker button to turn everything off, which I don't think US spec ones do. 

Link to comment
Share on other sites

Appreciate whatever light you can shine on the issue.  I am an experienced electronics technician so I know where and how to be safe.  I just wish I could find a wiring diagram for the E1 so I could troubleshoot it easier.  I probably could even repair the charger itself if a schematic was available for it.  Hopefully others will weigh in here with more info.  Any little tidbit could be a clue down the right path.

Link to comment
Share on other sites

So after studying the schematic, I started looking for the 30A fuse that goes from the charger to the batteries.  I found it mounted to one of the batteries.  The fuse holder had actually melted.  I replaced the fuse and holder and the charger started right up.  I kept an eye on temperature of the new holder and the wires running to it.  They get quite warm, but not enough to melt the new holder at this point.  I am worried what made it so hot in the first place and am concerned it will happen again.  We'll just have to wait and see.

  • Like 1
Link to comment
Share on other sites

We change the fuses (Also a lot of E1s dont actually have a fuse on the charger) on the Hisun and the Ranger for a maxi bladed fuse    https://www.ebay.co.uk/itm/143778366533  like these , not for high value fuses, but as they have large blades the connection is much better and the heat generated is virtually none. The ranger is the worst, they use the mini automotive fuses, The only issue is connecting them into your loom. So make the terminal to the contactor the longest leg of the fuse holder with an 8mm crimped terminal, and the other end ideally crimped to the original loom section. Any join should ideally have one or more layers of heat shrink sleeve.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By qajeff
      Ok, battery was original, replaced it yesterday with a new one, fully charged ant went for a spin, noticed the red battery picture on the dash screen, also after 10 min drive, the power steering was jerky, like it was cutting out. I am thinking the unit is no charging when the unit is driving, should not have a light with a fully charged battery out of the box. Any suggestions, on what to replace ??
    • By rsar
      Just got quoted $770 for my Mule's first 50 hour service. Is it just me, or does this seem insanely excessive? I was expecting something in the $350 to $500 range and thinking that even $500 would be a little high. Is dealer service really necessary at 50 hours? At this price I think I'd like to shop around for a mechanic that could do it for half the price. I don't really have the option of shoping around for a cheaper Kawasaki dealer, as there is just this one dealer a reasonable distance away (30 min). The next closest olne is 3 hours away.
    • By rmissildine
      Hello all.  I'm new to the forum and have read all the posts I could find concerning the 550 Mule, so far no one with my problem. So, I'll give it a go and hopefully get an answer.
      I got this mule about three years ago, had to do some minor repairs, and it's been a great machine. Last fall, I noticed an oil leak coming from the left side around the crankcase cover.  I was able to slow the leak considerably, but it still leaked.  I never had the time to tear it down due to work. I retire in March of this year and decided to fix it with a new cover gasket. I ordered a new gasket and crankshaft seal and while waiting for them to arrive, I began the tear down and cleaning of the mating surfaces.  Got the seal and gasket installed and the cover back on and torqued. Decided to crank it up and let it idle a bit to check for any oil leaks before I put the converters back on. Fired right up, let it idle for about 10 minutes, no leaks. I'm happy at this point...
      Next day, installed the inside converter cover, new belt and converters, not the outside cover though. I wanted to see how the new belt was going to work out. I still had the rear end jacked up so it wouldn't move.  Guess what, it wouldn't start up. Cranked over like always, just wouldn't start... Now I'm bummed. So I start checking gas, spark and everything is good. Even tried a squirt of starting fluid, and it did fire a couple of times but no start. Now I'm even more bummed. Time for a break.
      Now I've worked on everything from small engines to tractors and have never had this problem.  After a little thought I decided to run a compression test. The repair manual lists 115 - 178 psi as the correct range, I had 30 psi!!!!! What in the world happened over night. I did spray a light oil into the cylinder and it came up to about 60 psi but that was all I could get. I checked the valve clearances, their good.
      Sorry for the long post, but I hope someone can point me in the right direction cause I really like this little machine.
      Thanks for your help,
    • By dalem
      Earlier this year my battery was weak and I had to boost my mule to start it then I decided to remove the battery to check the fluid level which was very low, I set the levels and recharged the battery a few months later it did the same thing, so I had to boost it again then checked the voltage running was getting around 16 vdc ( which is too high) and fluid level was very low again and wouldn't hold a charge. Note: The battery was maybe 1-1/2 years old. Then I replaced the battery and checked the voltage running nothing changed I was only reading battery voltage it wouldn't increase with increased engine speed. I changed the voltage regulator with an aftermarket  one, same thing not charging. I checked the alternator per the service manual which states .3 ohms or less it checks at .2 ohms and not shorted to ground. With the engine running I disconnected the alternator and it had around 22 vac idling and around 60 vac revving the engine, so I figured the regulator was bad so I replaced it with another new one (aftermarket) from a different company, again not charging only reading  battery voltage. I did put the original voltage regulator on nothing changed still not charging. Using the manual wiring diagram did continuity checks going to the voltage regulator everything checks out OK. Now what am I missing?
    • Get More For Your Device
    • By Terry B
      We purchased this UTV less than 60 days ago and now I am having issues with drained battery. Used UTV for about an hour then stopped and when I went to start back up my battery was to low to start it. Jumped it and it started right up and ran fine back home. Tested charging and it’s not charging while running. Can it be anything other than the stater??? Can I look for something that I can fix Quik or does it have to go to the authorized service center to stay under warranty? It will take some time to get it in and out of service 
  • Gallery Images

  • Create New...