Quantcast
Jump to content

charlie

Rzr 570

Recommended Posts



My cousin has one. He said its A ok, but quite under power. Maintenance is the same with other brands and model. Parts are also abundant.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By OldGoatLover
      I bought this thing last September.  The farm store was extremely nice. 
      But, forget asking for any advice like in the old days.  They only SELL them and tell you to call the Dallas tech person.  
      During the week days - I don't have time.  
      Oil change:  If there is someone who can tell me why the owner's manual (and the internet) says it holds 2 and 1/2 quarts of oil but, my mechanic could only get 1 and 1/2 quarts in it and there is NO oil filter.  
      Please help.  
       
    • By Buggs63
      Sometimes when I go from neutral to high, the machine will not move and I have to move the shift lever back and forth until it go into gear, and the strange part is when I go from reverse to high to low, it stays in reverse and I have to turn the machine off, move the shift lever a few times then I can start and take off in drive, please help.
    • By Cub owner
      Ok trying again... I have 2018 cub cadet 750. Having clutch issues. Has anyone bought a upgrade for them and where did you get them and about how much. Thanks for any help given. From what i have looked over on here. Lots of nice helpful people 
    • By Robert Sawyer
      So I have a 2018 Massimo 500 and bought with 100 miles on it and only 400 now. It has worked and ran perfect. I noticed towards cooler weather it wasn’t idling and then just not running good at all. 
      things done - replaced the ignition coil replaced the plug checked cord for voltage. Drained gas cleaned tank went to a Rec fuel. Cleaned fuel filter screen at bottom of fuel filter. Cleaned main line and screen (had some residue) no air leaks I can find. Checked cleaned air filter. Cleaned and tested air intake control. Removed cleaned and tested the device moves o ring also fine. 
      I am not at a loss I can not get it back to where it was I have attached video of running etc 
      HELP 
      IMG_1823.MOV


×
×
  • Create New...