Quantcast
Jump to content

Travis

Mule 610 VS. Polaris Ranger 400

Recommended Posts

 

ONE THING THEY DON'T MENTION IN THE SPEED TEST, IS THE ALL Mule's are governed at 25 mph.

Share this post


Link to post
Share on other sites


I do know most rangers are superior to Mule, but from what i've heard polaris' are pretty unstable when going fast?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JohnBoy
      I recently bought a 2010 Hisun 700 UTV and have been having a heck of a time with the throttle cable and carb.  I did get it to 38 miles an hour, but now its dropped to 33.  Is that the full speed for this buggy?  I am on my second throttle cable trying to find the correct length to make the speed consistent. I floor it, but it takes a good while to get up to speed.  What is everyone else getting for speed?  And any ideas on how to set the throttle cable or adjust the carb?  Thank you!! 
    • By Richard Schleper
      I have a new Buck 400 with about 60 miles on it. It runs great but can only get it up to 23mph. Is this normal? If not what speed are others gettting.
    • By Mark Stermer
      I purchased a Gator 625I recently and after owning it for awhile realized  the top speed was limited to approximately 25 MPH. I talked with my local JD dealer and they told me this was done on this model for emissions reasons. I didn’t buy this for a racer but would like a top speed of around 40 MPH. Is there anything fairly simple that could remedy this? Thanks
    • By Everyday Medic
      I have a 2012 HS700UTV EFI, I am from canada so it was marketed under the name power max roughrider 700. I use this machine to plow and general yard work. I have been slowly over the years working electrical bugs out.
      Yesterday the SxS well my son was using it began to make a wire burning smell.  We found that the wires coming into the voltage regulator/rectifier had burnt and melted the plug. Because if this I will be replacing the voltage regultor. 
      Before I replace (have to the plastic is destroyed) I wanted to test the stator to ensure that there was not an over power. Now I know this is very very doubtful as I believe wires in the harness had shorted eachother causing the melt down. But just to be sure.
      I would like to know if anyone can answer, what the ohms reading should be across the windings of the stator. It is still in the bike.  
      Second, there is 5 wires... 3 white they plug into the bottom or back side of the regultor.  There is one black and a red with white strip, which two terminals would these plug into on the front of the regultor? I know the center front is  it used as this is plugged on the now melted connector.
      Thanks for any advice and help.
      John.
    • By Terrypenton
      Bought this machine a couple years ago and the gages didn’t work.  I have troubleshot this thing numerous times to no avail. Thought it may be a common ground so I individually grounded  the gages, didn’t work.  I have tested the sending units.  All have some resistance that changes as the engine revs or gets warmer.  Please help me.  Thanks in advance


×
×
  • Create New...