Quantcast
Jump to content

I have no clue....


Thaguy
 Share

Recommended Posts

If it can help you the vector 500 only need 1 batterie. But like any hisun fan,starter are an amp eater. The charging system cannot support all of that amp comsuption. Starrter and fan not enough whit the OEM batterie and the charging system.

A good small batteries upgrade is a honda civic batteries. Enough cca for the starter and fan will run less too and faster.

For parts is hisun directly

Link to comment
Share on other sites

Thank you for the response. I am working on the fuel system now. He broke the nipples off the fuel pump that the lines connect to. Im trying to figure out the feed the return and vent.... The pump puts out a ton of fuel when you switch the key on.

Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By Roadstar515
      My drain plug is leaking at a slow pace but enough to be leaving oil on floor. Talk to dealer and I replaced o-ring and checked mating surfaces and all good. Still leaking but at a slower pace. Now dealer is calling Hisun to see what’s up. I’m thinking the recess in the drain plug was cut to deep and when installing o-ring it just doesn’t seem to leave enough rubber above the flush/crush portion of sealing surface. Maybe a defective drain plug, that would be my guess. Wondering if anyone has had this issue with there’s. Dealer said this is a first for him. Waiting on reply from dealer.
    • By amautv
      1 1/2 years ago I was riding along in my 2018 Coleman 550 Outfitter when the CVT belt broken.  Just prior to that I was having some shifting issues that I now understand can be part of the clutch. Finally a few months ago I sent it in to a shop who put in a new belt as well as a new wet clutch (drum, one way bearing, etc and an oil change) He fired it up and it turned on fine, sounded fine and I took it home. It was an auto shop but not a UTV specific shop. So get it home and after a half hour or so it started making some noises with my 10 year old driving it around. I get home and he said theres noises again and I played around a bit. Within a short bit of trying to drive it around I started having noises that I now understand was my One Way Bearing being destroyed. Aka metal noises from the bearing falling apart.   Of course, after the cost of $800 to take it to a shop plus $200 in gas, trailer rental etc to take it in and back (it was a friends shop that was a bit of ad istance) I was quite ticked and pushed the UTV back into my garage and left it for a while.  Then this past weekend i watched a bunch of Youtube videos along with a mechanic friend to pull things apart.  We found the spindle was loose, opened it up further and found the one way bearing fell apart in my hand and the little bearings were already worn, no longer round and this was from less than a hour of use. THerefore leading me to believe it had very quick failure after the new wet clutch was put in.  We looked things to look for damage further.  Nothing really scratched/grooves etc so I ordered a new OEM bearing and we put it in, sealed it back up, followed the specs of everything and was 110% sure we put the One Way Bearing in correctly.    We rode it around for a hour, sounded fine.   Next day used it, sounded fine for a half hour.   Third day I turned it on and let it idle a little bit and found that I was hearing metal scraping again like I did right after getting my utv back from the shop.  Therefore I am 99% certain the One Way Bearing is about to break again (already breaking)   Its a brand new OEM belt.  Nothing looks off on the spindle.   I do not know for sure if the shop touched the inner race for which, in my understanding, the One Way Bearing spins. I know I may be sounding ignorant here.  I am not a mechanic by any means but I have learned a bit with the recent Youtube videos and attempted repairs.  Whatever that "ufo" looking object is, we replaced the bearings (those black things that spin) I replaced the whole "Ufo" lol... as the original had some wear/tear that prevented it from spinning perfect. Nothing currently
      visibly looks off... and the issue is mostly when the machine is more in an idle.  It was at an idle when the One Way Bearing sorta went kaput the last time.  THe noises is at an idle... but if I can get it drive, its fine.  It also affects the ability to shift the gears. 

      I know I will have to replace the One Way Bearing again... I just dont know what might cause the issue that is destroying the bearinga nd so quickly.   Again, this all started when the belt snapped when I was going about 15 mph down a road on a warm day.  It has higher miles.  The wet clutch was in bad shape and its replaced.   The paperwork says "wet clutch assembly kit")   Is there something that the belt can do to cause damage that might not be as visible but would directly create an issue that lets the bearing get ate right up?? Help me!  I hate this machine and I really want it to run well ... so I can sell it and find something else  haha..
    • By TELEPHONEMAN
      I bought a 2001 Kawasaki mule.The wiring has been torn out.I can get it started by running a jumper to the solinoid but can only shut it off by pulling spark plug.What happens through ignition switch that would shut it off?
    • By ExploringLife
      Hello all, I have a hose that is in need of replacement but I don't know what it's for. It's twords the rear of the engine down lower, I've looked around for a diagram or an exploded view but can't find anything, I'm assuming it's a radiator line but idk. I guess I could just disconnect it and I'm sure I'll find out real quick what's in it. 
      Also are these hoses cut and sold to fit or do we need to just buy (whatever) length of hose and just get it in there?
    • eManualOnline
    • By MaxMuncey
      Greetings all - I'm on a national hunt for a General XP 4 1000 Trailhead Edition. Just purchased a 2-seater and would like a matching 4-seater. Needs to be an in-stock/available unit as I do not have the time to order and wait. Open to potentially a slightly preowned unit too. 
      Max Muncey
      248-763-6116
  • Gallery Images

×
×
  • Create New...