Quantcast
Jump to content

Joyner Parts


bigdan120
 Share

Recommended Posts

She is a woman in China that I have become friends with.  Please have part numbers and double verify them because shipping is ridiculous from China on heavy parts. She does have stock in USA.  She cannot verify what you need. She does not work for Joyner. She only sells parts. She or I will post her contact info on here. I believe her info is in the Parts section.

Link to comment
Share on other sites

She is a woman in China that I have become friends with.  Please have part numbers and double verify them because shipping is ridiculous from China on heavy parts. She does have stock in USA.  She cannot verify what you need. She does not work for Joyner. She only sells parts. She or I will post her contact info on here. I believe her info is in the Parts . Here it is.

[email protected] 

Per Casey Ye

please help me to inform them that i Have ordered 20 pieces of 650 rear CV axles which will be available in beginging of April. if They want They Can contact me. I willconfirm exact available time after Chinese New Year Holiday. Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By Hisunsadman
      I have recently acquired a 2012 CFMOTO 500 CC side by side. The previous owner said that it ran great but had a gas leak by the throttle body that caught fire and ruined most of the parts on top. It also melted the cover and fan for the stator. Does anyone know of a good place to get all of these parts? I usually use Amazon for all my 2020 hisun parts, but can't really find the ones I need for this. If anyone has any ideas I would greatly appreciate it. Thanks in advance
    • By Michael Hudson
      So my wife picked out a brand new Hisun crew 4x4 750 axis 4x4. When it gets hot it shuts off. This vehicle has less than 20 miles. I'm the dark here. First I have no access to a trouble shooting guide and have even blindly performed the "wiggle tests" as I used to do as a drive ability tech on cars professionally. I'm not able to locate what's getting overheated to cause it to shut off. After awhile it'll start right up and no issues. While trying to duplicate the problem sitting at idle, it'll eventually cut off again. Again when cooled off will start again. 
       
      I'm hating this machine and wished she'd gone with a pricier but more reliable sxs. My grizzly 550 rarely gives me issues that isn't my fault. 
    • By Zero
      So i have a 2011 EFI 700. the SxS will crank right up everytime without any issues. If i let it run or ride it for about 10 mins it will shut off and then it may turn on if i am lucky but most time i have to let it sit for like 3 hours and then it will run again. i have done the following
      -New fuel filter
      -New injector
      -New spark plug
      -New coil pack and plug wire
      -New air filter
       
      Also could i get a grizzly 660 engine and put in it or would it not work.
    • By IslandHopper
      Can anyone tell me if their MSU 500 or 700 fuel pump and injector cycle when you turn the key on? This will help me rule out the Crank Position Sensor as a problem.
      I just bought this non-running and the service manual is not much help.
      Thanks
    • eManualOnline
    • By Steven78
      Hi I have a t boss 410 is about a year old with 150 MI and it feels like the brakes are stuck when you take off but in neutral it rolls perfectly I also have a t boss 550 that does not do this so was just wondering if anyone else has had this issue or if it is common with this machine also on the 410 have had the stator motor and voltage regulator replace once already and think it is bad again not sure if this would have anything to do with the other issue any help or advice would be greatly appreciated thanks in advance

×
×
  • Create New...