Jump to content

2018 Sector 250 hard to start, won't idle but runs great


Recommended Posts

Hi guys,

I have a Rural King version of the Hisun Sector 250 with about 75 miles and 15 hours on it.  It just started being difficult to start and idle.  But if I hold in on the gas a little it will start and run until I left off.  It also runs good and will run good until I stop then it idles for a few seconds then quits.  Its about 4 months out of warranty.  Battery voltage is fine before, during, and after starting.  Oil is clean and clear.  Gas is fresh.   I can hear the fuel pump spool up when I turn the key to actually start it, not when I turn it to the on position though like on most other UTV's I have owned.  Its really odd and has me perplexed.  The only other thing that I have noticed is that the engine temp indicator on the left side of the dash only indicates one bar regardless of how warm the engine is.  Other than that, it runs great.  Just hard to start and won't idle.  Any suggestions?  It has me  perplexed.




Link to comment
Share on other sites

3 minutes ago, Travis said:

Carbuereated or fuel injected?

Fuel injected.  I checked a few more things today.  After cranking it for about 7 seconds and not "starting it by pressing on the gas" I checked the spark plug and it was wet.  It was also a little black for a plug to have that few hours.  So its getting fuel, maybe too much but once I put it in gear and take off it runs like its normal.  Anything 500 rpms or higher than idle speed it runs great.  Could a slightly weak battery starve just enough voltage at startup to not make the plug fire good?  Then when the rpm's are up the stator takes over?  Just guessing.....



Link to comment
Share on other sites

  • 3 weeks later...

Thanks for your replies guys.  I might have fixed it.  I changed the idle air control valve.  That seems to have fixed it although I have only gotten to test it briefly as the temp here is cold.  I had forgotten that these fuel injected ones have an idle air control valve.  The old one seemed to be stuck as to not feed any air while trying to start the engine.


Thanks again and will update thread if appears to not be fixed upon further testing.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...