Quantcast
Jump to content

Recommended Posts

Bike is pretty much brand new... was rode very few times... less than 20 hours. asking $4,000...call and make an offer though.... 606-432-1556 Mike

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Monty Herbold
      What is a good oil for the 1100 just bought it and wanted to know what weight of oil and brand?
    • By Travis
      https://www.kawasaki.com/Products/2018-MULE-4000#gallery-videos-11663
    • By gpowers
      I have a 08 500 ruesch. I was wondering if they was a muffler that would fit it that would make it quiter l.
    • By Darryl223
      I've had a 2016 trooper for a few months, it's never worked properly.  I'm about ready to take it to a dealer for warranty work but it's a little far so I'm trying to avoid it.  It on occasion will not start. It took a while to figure out that if I open the throttle just a little bit it will fire, I then have to hold it open for anywhere from five to thirty seconds for it to idle on it's own.  Other times it fires right off no problem.  
              It's turbocharged, and has two pumps.  I've verified that the fuel pressure is correct.  Joyner has had me swap a bunch of parts to eliminate them.  I suggested it seems that possibly the IAC is malfunctioning or that it's getting incorrect inputs from the tps but they disagreed.  I've read that people have had similar issues stemming from the IAC but until I get a replacement from them I can't verify.  I tried setting base idle a little higher with the set screw but the idle just gets erratic and won't idle down once I've given it some throttle.  
             I'm going to call them again tomorrow and have them send a new throttle body to try, and I also have a scanner for European cars coming that is supposed to read chery automotive ecu's; after that it may be time to haul it in.  Anyone else had a similar issue?
    • By Travis
      Please include UTV year, make, model, cc, and technical issue (if you have one)...in your title when posting.  
      Having a well written topic title will ensure that your topic will be found in searches and that people know what they are reading, to save time


×
×
  • Create New...