Quantcast
Jump to content

Transmission's grinds on our Buck 450 when you shift it.


Farm Boy
 Share

Recommended Posts

It has done this since day one that we purchased it from Tractor Supply. I contacted the service man that Tractor Supply recommended and he told us that there wasn't anything he do to help us with. Has anyone had this same problem and can offer suggestion on to correct this issue ? It would be greatly appreciated.

 

Link to comment
Share on other sites

I do have a couple of suggestions, first always allow the engine to idle below 2000RPM, if it won't do that adjust the idle down to around 1800 RPMS, If that still don't work keep your foot on the brake peddle and kill the engine, then with your foot still on the brake shift into the gear you need and hit the starter, my 400 Buck will then start.

 

Link to comment
Share on other sites

  • 1 month later...

I also purchased a 2021 Massimo 450 Buck, have not had any issues until a couple months ago, when I shift to low range and then attempt to shift into reverse or shift to high it is grinding and doesn't want to go into reverse or high. I looked at the shifter cables and there are two of them thinking that I need to adjust the shift cable but not sure which way to go or which cable is the problem.

Link to comment
Share on other sites

  • 1 month later...

this is just the nature of the beast "gears grinding when shifting " make sure it is idleing BELOW 2000 RPM'  OR  STOP , kill the engine ,   shift Gear,  put your foot on brake and start the engine"

Link to comment
Share on other sites

See, thats the big problem with Massimo..  shops refuse to work on them because Massimo wont honor warranty and pay repair claims.. 3 shops here started out as  Manufacturer authorized shops.. now NONE will work on them because they NEVER GET PAID by Massimo..........One will work on them but only if you pay cash in advance because parts take months to arrive . Massimo is a horrible rip off company in Dallas TX.. When I tried to make them pay for repairs, It broke on its FIRST DAY in its first mile!!!     the Rep told me.... " NEVER GONNA HAPPEN!"   seriously, that what he said to me on phone .. They suck 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...