Jump to content

Hisun Axis 700---- Bought new, how to register the warranty?


Recommended Posts

I bought a new Axis 700 at Lowe's last Sunday, 7/24, and I didn't look through all my paperwork until the next day and there is no warranty info in the packet. I checked the Hisun site to see if you can register yourself and provide proof of purchase, etc., but they only have a form for Pre-Delivery & Customer Orientation Checklist which is to be filled out by the dealer and submitted to Hisun within ten days. I just called Lowe's and they're saying they automatically send it all in. How can I verify my warranty is registered with Hisun? I tried their phone number but of course right now it's after hours. I'll call again tomorrow but 10 days is pretty near.... I don't have any warranty claim yet but I just want to be sure it's registered.

Does anyone know a better way to check?


Link to comment
Share on other sites

Yup. Scanned in the receipt and called McKinney, TX. The gal said just go ahead and fill out the online form that dealers use and just fudge the fields where dealer info goes. She said all they really care about is the VIN and my info. I called back today and had them check to be sure it went in. She read my name and stuff back to me by looking up the VIN so I'm good to go.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By y2kbmet
      I'M STILL GETTING BACKFIRE UPON DECELERATION: 2 days ago, Strike was very sluggish, wouldn't make it up a hill. It is EFI with under 200 hrs. Yesterday, I replaced the plug with same exact I took out (NGK-R DR8EA), as it was covered in black soot. I cleaned the MAF with MAF Sensor Cleaner - not sure if I ripped one of the 2 o'rings pullling it out of it it was like that but either way, when I put it back in, it was seriously tight so I don't think that's affecting anything. I cleaned some of the throttle body (without removing it and without touching the flap), with Throttle Body Cleaner - it was kind of dusty. I cleaned the air filter which I replaced just 3 months ago when I did the oil change. All connections seem to be good. I could not find any exhaust leak anywhere. It got dark on me but I took it for a spin last night after putting it all back together and it seems to have it's power back but it's still backfiring when I decelerate quickly. Anybody have a clue what's next or had this issue before? TIA.

    • By Dirt Road Adventures
      Hello my name is Andy Seddelmeyer and I am from Decatur Indiana. I own a Honda Talon X4. I am also the owner of Dirt Road Design.
      I make accessories for SXS's but not limited to Honda. dirtroaddesignllc.com is the website if you would like to check it out.

    • By Ricky
      I bought this qlink 700 frontrunner from my father in law.  Went through a horrible divorce where my ex kept all my personal belongings and refused to return them.  Finally got a court order and she was ordered to return my items including the utv.  Utv sat for 3 years. I finally got it to crank but nothing electrical is working (fuel pump, instrument cluster, lights, horn etc...)  all the fuses are good, possibly a relay???  Where can I get an owners manual, parts diagram etc.?   I have no clue what year it is.
    • By Thumpalong
      Hello I have a 08 hisun 700 and apparently that year they had frost plugs in the cylinder head and were know to corrode and start leaking.  Well I have one and I have tried the jb weld to seal the leak but no go.  Is there anyone that can tell me the mesurements  of the cylinder frost plug hole. Apparently you cannot buy them  not available, so I'll try to source something if I can get the mesurements.   Thanks Thumpalong
    • DIY like a pro! Shop from over 1,000,000 Repair Manuals at eManualOnline.com! As low as $14.99 per manual. Shop now.
    • By robwork9
      Hopefully someone out there is a T-Boss 410 electrics expert or a Massimo mechanic is viewing this. I parked my 410 and it was working great. I came back a week later and attempted to crank it and nothing. Turned the key and no power. Figured it was a bad/low battery so I charged it. Still nothing. Attempted to jump start it and still nothing. Usually when I put the key in and turn it to the first position, the display comes on and I hear the ECU and other items boot. Now it is doing nothing. 
      I slowly went through the electrical system and found the main fuse attached to the starter relay, part 71602 (pic 1) blown. I figured replacing this fuse would fix my problem. It didn't. I then ordered a new starter relay thinking maybe that part had gone bad and caused the fuse to blow, but a new relay did not fix the problem. 
      I have found a work around for starting the machine. If I take one of the purple/black leads (pic 2) and insert one of them in the bottom right of the starter relay (pic 1 and 3) then the machine will get power even with the key in the off position.  I'm bypassing something but don't know what. I can use my right hand to hold the wire against the lower right of the starter relay, reach over and hold the brake with my foot, then take my left hand and turn the key and it will crank. As soon as I remove the wire from the relay the machine shuts down. I have even removed the power distributor box and it will still get power when I touch the wire to the relay. Of course this is not the way it should work but if I can't solve this problem somehow I may just have to rig a connector to the relay and bypass whatever is causing the electrical issue. Massimo has told me the purple/black wires on my model are not used.
      Any help in figuring what my problem may be or other items I can try?

  • Gallery Images

  • Create New...