Quantcast
Jump to content

UTV News and Information

UTV News brought to you from UTV sources such as sidexsideaction.com

466 topics in this forum

    • 0 replies
    • 807 views
    • 0 replies
    • 480 views
    • 0 replies
    • 533 views
    • 0 replies
    • 249 views
    • 0 replies
    • 382 views
    • 0 replies
    • 272 views
    • 0 replies
    • 352 views
    • 0 replies
    • 321 views
    • 0 replies
    • 345 views
    • 0 replies
    • 481 views
    • 0 replies
    • 232 views
    • 0 replies
    • 159 views
    • 0 replies
    • 203 views
    • 0 replies
    • 210 views
    • 0 replies
    • 183 views
    • 0 replies
    • 174 views
    • 0 replies
    • 198 views
    • 0 replies
    • 1,654 views
    • 0 replies
    • 628 views
    • 0 replies
    • 1,012 views
    • 0 replies
    • 598 views
    • 0 replies
    • 561 views
    • 0 replies
    • 665 views
    • 0 replies
    • 696 views
    • 0 replies
    • 1,240 views


  • Latest Posts

    • Hi Travis!  I think they ran it out of oil. Even though there is fresh oil in it now.  Has only 338 hours on it.   Mentioned a rod knock and-  that they kept using it. I bought it from a guy that works in construction.  Didn't get too hot at least.  It turned over, but makes clunk noises, when I get the side cover off,  the evidence will likely fall into my lap.    Paid $1500 for it, seemed like a deal for what we need it for.  Just hoping I can salvage what wasn't destroyed.  May swap in a Vanguard twin if I need to.  I have built many mower and ATV engines over the years, but never this setup. 
    • The engine manual matches mine,  very useful information,  thanks for the link. Here is one I found for the CVTech drive:  https://americanlandmaster.com/pdfs/UTV/Service/CV Tech Cleaning Procedure (2-20662 & 2-20660).pdf They have the tool, it's a bit spendy, hopefully I won't need it.  http://usa.cvtech-aab.com/176-extracteur.html  
    • Thanks Travis,  here is what im working on,  I believe it is a CVTech unit.  I soaked it good with some PB blaster.    Will see what I can do,  I don't want to damage it coming off.  Do I need to remove the large nut to remove it? I pulled a bolt out before taking these pics. Engine will be out tomorrow, gotta dig my hoist out in the back of the shop.    Thanks again.
    • Welcome to the forum!! Do you know exactly what happened to the engine? Ran low on oil? Threw a rod?
    • http://www.subarupower.com/wp-content/uploads/2014/09/subaru-engines-eh64-eh65-eh72-service.pdf   I believe this is the engine service manual for your engine.


×