Quantcast
Jump to content

Recommended Posts

  • 10 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By buckrub
      Hey guys! Newbie here. I'm an old man who's better with plowing a mule (4-legged kind) than these newfangled beasts. I, and a friend of mine, just bought new Coleman sxs and are having to finish the assembly. I've been reading on this site and I'm falling on the mercy of you experts. The only way I'm an expert is that an "ex" is a has been, and a spurt is a drip under pressure. LOL First off, the 2 buggies have no ignition switches. They seem to mount on the dash, not the opening in the steering wheel shaft cover, so we ordered new ones that are supposed to fit. They are 8 inches long, and have a 4-wired white plugin which is slightly rectangled when looking at the end of the plug. The trouble is there's nothing to plug into. There is a three-wire grey plug close enough to reach the four-wire plug, but of course, they are not compatible. 
      Secondly, the blinker, light, ect. unit on steering wheel just spins around when touched. I see no way in heaven or earth to secure it. I've looked at a diagram on the Powersports site, but can't detect how it mounted. Fellows I'd be so grateful for any help with this. Me and my mule will even plow your garden for free, for your help. LOL 
       
    • By Xov
      Just received delivery of a 2024 AMP Pro.  Thought I'd start a thread with my impressions as I use it and learn more.  There doesn't seem to be a whole lot of real-world usage information out there on this model.  Hope this will help others as they research.
      Intended Use Cases
      Fire mitigation / slash removal from a 5 acre forested and well-gamble-oaked property.  The previous owners thought as much about fire mitigation as I do about fashion: not much. Snow removal Stump pulling General hauling (rock, lumber, etc.) Weimaraner energy depletion.  Wasn't an original use case, but a nice added bonus.  Experiences So Far
      Wasn't impressed that two of the bumpers on the underside of the bed where it sits upon the frame were missing.  The metal on metal contact has damaged the powder coating and the frame.  I expect a little better QC.
      I've only put a few hours on it, so not a ton to report on usage.  It isn't quiet; it's silent.  I can't even detect an electric note from the motor. I removed (and subsequently replaced) the motor cover noticed that the motor is German and made by Schambuller.  The motor controller is Italian and made by Dana TM4.  Given the operating specs of both I found on the web, I suspect both are higher quality than the previous Navitas (which is supposed to be decent).  The motor is rated at 25 hp and 71.5 lb-ft of torque.  It feels very powerful.  All the torque is delivered instantly, if desired.
      The bed is huge and has an electric dump as standard.  Great feature but would like it to go up a bit more.  Probably not feasible from an engineering perspective, but I want and I need ;).
      Power steering is nice, but vague.  Probably common to many UTVs, but I am accustomed to more direct results from input.  Plan early and plan often.
      In our first full day of usage, we hauled about 1/2 as much slash as the entire rest of the year when I was doing it by hand cart.  I may get fatter, but I'll also get more done.  After a few days of usage, the battery meter has gone down by 1/10th. 
      Until next time...


    • By Nathon S.
      I have a Bennche 700 EFI Bighorn. I’ve recently been unable to get it to start. After a little troubleshooting I realized my fuel pump was not pumping fuel. This weekend I emptied the gas and replaced it with new. I replaced the fuel pump, fuel filter and fuel injector. I also replaced the battery, spark plug and made sure all my fuses and relays were good. I have confirmed that the float on the fuel pump is not obstructed. The UTV is about 12 years old and has less than 100 hours on it. It has not run in over a year.  Not sure whats going on?!? After doing a little reading I'm leaning towards it being an issue with the ECU or perhaps a faulty wire in the wiring harness. Anyone have any ideas on where to start looking or what I could be dealing with? Any help is appreciated, thanks in advance!
    • By REDfletching
      Spent today at a Honda dealership looking at their 520 side by side, then on the way home past our Lowes noticed they had several new UTVs on site, so we U-turned and ducked in there. We were impressed that all that came for $9,999 metal whole length skid plate, nice sized bed, roof, windshield, side mirrors, winch, upgrade looking tires… all of which would have added thousands of dollars to an already expensive Honda 520. Now Honda does have a great reputation from my trusted UTV experienced buddy, so it has that going for it.
    • By Hi sun 500
      hello everyone, i just joined this forum to try my luck, few days ago i bought an old (dont know exactly), 2011/14 hi sun 500cc ""carburated"",  was not running at the time, but i fell was a good deal and decided it to bring it home to play with it, this is the issue, i bought and installed a new carb, and pump, i repositioned the battery location and upgraded to a "car batt", reconnected the fuel lines and started it, but it only runs with the choke ON, i checked the bowl, it does have fuel,but for some reason wont inject it to run, i came across a video that say that ""the body small tank had to be connected for the cart to run" (was deleted when bought), sure enough i got it to run sporadically , but the so called ""small body tank'' often runs out of fuel and wont refill itself , i had to couple times do it manually, so how does that small tank works ?..what does it do?..and why if  bypass it , the cart wont start?....any help?..thanks so much!!!
×
×
  • Create New...