Quantcast
Jump to content

09 joyner trooper t2 1100cc


shady light

Recommended Posts

Hi everyone! I am the new proud owner of a 09 joyner trooper 1100cc.. unfortunately it has a few issues.. alternator, red shift cable,and power steering pump needs to be replaced.. it seems these parts are pretty pricey on any of the joyner dealer sights..i saw someone on here that said they have parts cheaper... any help would be greatly appreciated! Thanks in advance 

Link to comment
Share on other sites

  • 3 weeks later...

Welcome to the forum. 

I don't get on here as much as I used to. 

Man, as far as I know not many troopers had a ps pump. Can you get pictures? 

I suggest finding alternative sources on as much as you can. If you can find an alternator or ps pump at the local autoparts store then you can just get it whenever and not have to order. I am certain there is info on this forum about another type of alternator that will work. Just keep searching. 

Link to comment
Share on other sites

On 11/20/2017 at 0:51 PM, shady light said:

Hi everyone! I am the new proud owner of a 09 joyner trooper 1100cc.. unfortunately it has a few issues.. alternator, red shift cable,and power steering pump needs to be replaced.. it seems these parts are pretty pricey on any of the joyner dealer sights..i saw someone on here that said they have parts cheaper... any help would be greatly appreciated! Thanks in advance 

Sounds like you bought a machine that has been modified with hydraulic steering.   Bad news in my opinion.  If the wires in the alternator still look good, it could just be the brushes, I've fixed a few for fellow members, just charge for shipping and parts I have to buy to fix it. 

Take some photos of the rig and the bad parts and post them. Plus, fill out the profile, maybe one of us lives just around the corner

Link to comment
Share on other sites

This is the hydraulic steering pump.. Probably also not a good enough pic.. it is located on the bottom right rear of the engine and machine.. the reservoir is a cast aluminum square box located on the front of the frame just under the hood.. my question is.. is it supposed to be vented? Because it is not.. it seems to be a sealed system 

Screenshot_20171211-092801.png

Link to comment
Share on other sites

I'm not a fan of any "cure in a can" solution, but you might try some belt dressing.  It makes the belt and pulley have a slightly higher coefficient of friction.  If the belt is slipping, that may help.  The squealing from belt slipping is different than a whining from low PS fluid level.

Another thought of mine.  Most PS systems that I'm familiar with  have the reservoir at the pump or very close to it.  Yous is located quite a distance; probably because of clearance problems with the installation.  That could be an issue.to consider.  Pumps are of four general types: a combination of high/low pressure with high/low volume.  PS pumps are Low Volume High Pressure.  They aren't capable of drawing a high vacuum through a long line.

Link to comment
Share on other sites

Which leads me back to the original reason why i am mythed about it.. works fine after i turn the steering wheel back and forth a few times... belt is tight.. apparently good pressure... im thinking debris in the system.. if not it my be a check valve for ventilation.. but no one has confirmed weather or not it is a closed or vented system... no one knows anything about my abomination lol.. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By CBS
      Greetings from Southern Illinois. My name is Bruce and I currently have a Hisun HS550 Performance Rural King. I have had nothing but problems with this unit replaced so many parts of it and of course, it stopped working and will not start again for about the 3rd or 4th time since 2018 it only has a little over 500 miles and has cost me a bunch of money and headache and the Rural King where I purchased it has a repair man who is certified to work on HISUN but he charged me a little over $600 to repair it once back a few years ago and when I got it home after it being in his shop for over 2 weeks the thing worked for a very short time but when I went to start it the next day it was the same thing and they wouldn't check it further without me paying for service, labor, and parts and I went around and around with them and since there aren't any dealer service centers for Hisun near me and even most of them can't get to it for weeks to months and it could be at their shops for months as they tell me they have problems getting the parts needed from Hisun to fix these giant paper weights. Oh, and you can't buy a scan tool (code reader) Delphi 190121 unless you are one of their dealers and I can't find any other scanner tool that works with it except the Tiny Scan Tool which I purchased and it will work if I could find the correct adaptor cable and connector to connect the Tiny Scan to the diagnostic port on the Hisun HS550 Performance Rural King. Yep, I pretty much have been screwed every which way that can happen with this machine. I am disabled, have cancer, and am on a fixed income so I need help if anyone knows what the connector is called (type or part name) that will plug into the diagnostic port to get my scanner to work it is a 6-pin connector and I hear it only has to have 3 wires connected to it.
      Thanks 
    • By Bryan g
      We see a lot of the UT400 with shift problems, not going into gear, popping out of gear, grinding etc. There  is a bulletin Im sure everyone has saw about adjusting shift cable.  That dont always fix it.  I went round n round with coleman  on couple units. We are a Coleman warranty repair center"AFS Small Engine Repair "   I told them shift lever does not have enough travel .  No amount of cable adjustment  will increase travel . I  extended lever with piece on flat  iron by 3/4 of inch .  This gave shifter enough travel to properly engage into gear completely .  Last couple units to come in for this Coleman sent me a modified shift lever, with longer travel . Problem solved! Also , heads up if you get any new unit ,,,go over and check it out,  grease  all zerks, check air filter for being in backwards, check wiring harnesses for rubbing on rotating parts,  brake hose  routing , make sure not touching exhaust .  These are just  few of the more common failures I see .
    • By CYJSP2009
      Dear Joyner owners
      Any one who is looking for below Joyner parts please send email to casey from Leaf Asia  ( please send to [email protected] and cc to casey2leafasia.biz & [email protected])
      Currently, we have supply below parts: 
      1.  cv axles, cv rebuild kits, cv boots
      2.  Differentials and differential ring and pinion set
      3. Cables, 
      4. Brake parts
      5. Engine parts
      6. Other parts. 
      We will provide better price, close follow up ... 
      We can arrange productioni for parts that we can collect demands from customers  
      Have a good weekend
      Casey /  Leaf Asia 
      2023-11-17
       
    • By goindeep
      Well now i could use a lil help... i have a trooper in my shop now that has wiring issues... this poor guy paid another shop $1000 to re wire the body control harness, and boy oh boy did they chop it up!!! I am Buillding a new harness from scratch... what i need is a diagram that tells me what each fuse and relay control on the Engine fuse/relay block.. any help is greatly appreciated!!
      Josh
      No Limitz
    • By FloridaMan
      I have a 2012 Massimo MSU 500 that died. I found that it didn't have spark and the fuel pump wouldn't run. Checked all fuses and none were blown.
      Went through and replaced the ignition coil, HT lead and spark plug. Still no spark.
      Thought it could be the fuse/relay box because I didnt' know much about the machine at that point so I replaced it. No spark.
      Then I replaced the ECM just because I was running out of ideas. No spark.
      I removed the 9 pin connector and hardwired it making sure that they were no wires got swapped. Still no spark.
      Then I replaced the wiring hardness. In doing so, I replaced the 9 pin connector with new ones. I made sure all wires were matched up between the engine harness side and the other harness assembly. Still no spark.
      I have no other ideas what to do. My fuel pump doesn't kick on and I have no spark. I have 12V on the fuel pump, ignition coil and fuel injector, but no ground from the ECM control.  I unplugged the fuel injector and waited for a diagnostic code but nothing ever came in. It makes me think that the ECM isn't powering up. I've checked for 12V on pins 18 (purple wire) and 15 (white and black wire). I also checked for ground on pin 2 (black wire). All are good.
      I am out of options here and I have no idea what else it could be. I have all connections redone and are coated with dielectric grease. I've checked all easy things like fuses and making sure I have 12V in the right placed. I would appreciate any help.
×
×
  • Create New...