Quantcast
Jump to content

2012 hisun front runner 700 efi


Beetle1
 Share

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By Tombo
      How can i Disconnect Hisun 700 2017 UTV  40 km/h speed limiter ? Preferably with a switch. 
       
       
       
    • By Louis Limoges
      Hey guys ! I installed a snow track set on my 550 UTV last year and it does a great job even though the engine is not that big. Broke 2 wheel studs so I temporatily replaced them with bolts but I would like to go back to the studs before reinstalling the tracks this winter. Any idea what the default studs are so I can order replacements ? Thx !
      Edit : Any reseller to recommend if I want to order them online in Canada ? 
    • By EJW
      I have a 2011-12 Hisun Yard Sport HS700. Engine gets hot, but radiator does not. Changed the water pump, still the same. Service manual parts #15, 16, & 17 (pages 283-284) shows a "Save Temperture" #15, which looks like a thermostat. Service manual also parts #9, 10 & 11 shows it without a thermostat. Does this unit have a thermostat?
    • By Jamie
      Wondering if a soft roof that’s made to fit 2012 prowler will fit 2016 prowler.  I have the HDX XT three seater. Wondering if the shape or size of their roof changed
    • eManualOnline
    • By Fib103182
      I have owned my 2015 Hisun HS700 Crew  for about 3 or 4 months now. I got it used and was supposed to run good but was not put all the back together from a stator upgrade due to previous owner said he was going to out a stereo system on it. Anyway I have worked it much more than I have rode it. I seem to work on it 2 days and ride it for a hour. Me, my wife, and 2 kids (10 and 18) enjoy it but the engine compartment gets so hot. I've replaced the water pump and burped the cooling system and any other thing I could think of to bleed the air out and think its good with no air and water circulating. Fan seems to run fine and be on about all the time. Changed the coolant twice and oil 3 times. I noticed the engine really has nowhere for heat to go because heat rises and no air flow at all. Has anyone had any experience in this area? Any DIY tricks or any advice in removing the heat out of the engine compartment and getting it to a tolerable temperature. Im about to sell it if I can't figure something out and go waste money on a big name brand but I won't have red legs and arm from engine heat burning me and my wife. They machine never acts like its to hot or anything but it feels like it is. Thanks in advance for any and all help. 
  • Similar Tagged Content

    • By Tombo
      How can i Disconnect Hisun 700 2017 UTV  40 km/h speed limiter ? Preferably with a switch. 
       
       
       
    • By Zero
      So i have a 2011 EFI 700. the SxS will crank right up everytime without any issues. If i let it run or ride it for about 10 mins it will shut off and then it may turn on if i am lucky but most time i have to let it sit for like 3 hours and then it will run again. i have done the following
      -New fuel filter
      -New injector
      -New spark plug
      -New coil pack and plug wire
      -New air filter
       
      Also could i get a grizzly 660 engine and put in it or would it not work.
    • By ANIL SEDALI
      Hi friends. I'm Anıl. I live in Turkey. I have a Hisun 700 UTV 2015 Models. My problem is : 
      inability to change gear after the engine has started. Before the engine starts, it can shift into all gears; but after running, I cannot change gear. At about 3000 km. Fuel injection model. Can anyone help on this topic? Thank you!
    • By albert schewe
      my name is albert i have in my shop a hs700utv that im getting no fire to coil i replaced the cdi  and checked the relays and ignition switch out getting power to the cdi but nothing to coil and i didn't find any broken wires. they said that it was running fine and then it just stopped and  wasn't getting any power to the coil  is their another sensor on here that will stop it from firing  i have looked at a wiring diagram but im not seeing  anything different from what i know  i checked the cdi and im getting fire to it but not to coil and this is a second coil no difference  and also this is a delphi cdi 2 port is their any way to check it i know im getting power to the black  plug in cdi  on the # 10 the green and black wire but nothing else the blue and black wire is opposite of it the emergency brake and neutral switch is working  is their a obd II plug for this i found one in back of pickup bed but i cant find a scanner but im not sure if it is one  and im getting power to the stator the threee wires  im at a lost here 
    • By Julie Doeppke
      We bought a Hisun 700 UTV, used. It has an issue when you run it in high. It drives but acts like it is shifting when you get around 35mph. Clutch looks good. Read many articles and not sure transmission or something in rear of UTV. Looking for any advice.     
  • Gallery Images


×
×
  • Create New...