Jump to content

Trooper loud clunk in front


Recommended Posts

I'm having a loud bang in the front every now and then. It sounds like it comes from the left and right wheels (alternately). It doesn't do it on flat road at all, only on a rutted dirt path. At first I thought it was the suspension violently reaching the extent of it's travel, kind of like a no rubber metal on metal bang.

I just got it (used) so it's a mystery how long this bang has been there.

Any ideas?

Link to comment
Share on other sites

agreed with Bigdan ...also Quite often you will find loose shock bolts at one or both ends of very stiff sprung shocks..also having stiff front shocks tends to "jarr" or bang the suspension back to the top..there are lots of bolts and joints to bang up there...pay particular attention to the upper and lower balljoint

( the joint itself ,where the joint fits the a arm..and where the pinch bolt joint is) for movement/loose parts...hate to see something come apart ...Hardy

Link to comment
Share on other sites

I don't think I have ever pin pointed where it's coming from, but I do think its every little ounce of play in the suspension bottoming out all at once, I still have it after 20,000 kilometers!

I tries using limit straps, not help, It seems like my most productive attempt was to make the front end suspension as lightly sprung as I could, but I have some 200# springs which I think is a bit too much. Seems to happen on rebound.

Link to comment
Share on other sites

  • 1 month later...

No, I haven't gone fast enough in 4x4 to even try it. 4x4 all locked is so hard to turn it's basically useless unless I'm in a jam (mud)

It never happens cruising down the pavement. It appears to only happen when one of the front wheels come off the ground. I don't know if it clunks when the wheel leaves the ground or when it hits back on the ground, but it is violent. I would compare it to a 5lb sledge hitting the frame (with considerable force). My steering box is so loose that I'm going to try that first. I'm considering a replacement that might help ease up the 4x4 steering vs just applying the looseness 'fix'.

Link to comment
Share on other sites

This might sound dumb but see if you can do a video with sound for us to hear... maybe take pictures of all your front end with tires off...

As far as steering in locked 4x4..

I believe there all like that...

I installed my own electric steering. Can be done now for less then 300.00 if you can fab and weld..

Link to comment
Share on other sites

I mean, only when you're in 4x4? if so, it could simply be your diff lock cable is out of adjustment, even if you didn't use the diif lock. the adjustment is finicky and it will clunk loudly every once in a while if the asjustment is out.

Link to comment
Share on other sites

Crappy video of steering box play...


Hard to argue with that, crappy, looks like you need front wheel bearings, rock your tire like that and look for movement between the hub and the cv that goes to the axle. Lenny used to sell a fix for your play, but I think he quit making them, an alternative would by to put some shim stock between the top plate and the slider piece, maybe replace the top plate with a thicker plate or make it out of steel.

Link to comment
Share on other sites

Score!! $140 - http://www.protodie.com/Steering-Rack-End-Load_p_72.html

I'm pretty sure that one is the same one made by Latest Rage (http://www.latestrage.net/index.php?page=shop.browse&category_id=944&option=com_virtuemart&Itemid=1〈=en) which should be a direct bolt on replacement. The only thing I'm worried about are the splines. I read the Joyner version has 32 teeth and this one has 36 teeth?? I need to take it apart and count I guess.

Link to comment
Share on other sites

The bearings are tight... all that play is the rack going up and down. I though about fitting a piece of phenolic between the rack and the top plate... but for $140+shipping I might as well replace the whole thing (if it bolts right on)

  • Like 1
Link to comment
Share on other sites

  • 3 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By robwork9
      Hopefully someone out there is a T-Boss 410 electrics expert or a Massimo mechanic is viewing this. I parked my 410 and it was working great. I came back a week later and attempted to crank it and nothing. Turned the key and no power. Figured it was a bad/low battery so I charged it. Still nothing. Attempted to jump start it and still nothing. Usually when I put the key in and turn it to the first position, the display comes on and I hear the ECU and other items boot. Now it is doing nothing. 
      I slowly went through the electrical system and found the main fuse attached to the starter relay, part 71602 (pic 1) blown. I figured replacing this fuse would fix my problem. It didn't. I then ordered a new starter relay thinking maybe that part had gone bad and caused the fuse to blow, but a new relay did not fix the problem. 
      I have found a work around for starting the machine. If I take one of the purple/black leads (pic 2) and insert one of them in the bottom right of the starter relay (pic 1 and 3) then the machine will get power even with the key in the off position.  I'm bypassing something but don't know what. I can use my right hand to hold the wire against the lower right of the starter relay, reach over and hold the brake with my foot, then take my left hand and turn the key and it will crank. As soon as I remove the wire from the relay the machine shuts down. I have even removed the power distributor box and it will still get power when I touch the wire to the relay. Of course this is not the way it should work but if I can't solve this problem somehow I may just have to rig a connector to the relay and bypass whatever is causing the electrical issue. Massimo has told me the purple/black wires on my model are not used.
      Any help in figuring what my problem may be or other items I can try?

    • By cliffyk
      I had mentioned in a previous post that I had removed the front anti-roll bar from my 2020 Outfitter 400; I ran that way for a month or so without noticing any downside however recently I installed a 'suicide knob" (see below) to assist my Parkinson's disease affected arms in turning the beast--but after doing so i found that in the quicker, tighter turns the knob permitted the vehicle would nosedive a bit, dig in, and plow  on hard surfaces--not scary, but quite noticeably.
      So I put the bar back on. Then today I got about 1-1/2 miles down the main road on the nearby power lines, turned around and came home to take it off--with the bar on, at 25 to 30 MPH, the front-end of the beast jumped like rabbit at each bump in either wheel rut., for a nearly brutal and quite uncomfortable ride. the bar (20 mm solid steel) is far too robust for the weight of the vehicle. The front bar on my 3900 lb. Infinity M37 is 30 mm...
      suicide knob--for you younger folks:

    • By johnpeter
      2022 Polaris RZR Pro XP Ultimate Rockford Fosgate edition like new On Ebay

    • By cliffhodges
      Hi All- Long time reader, first time posting.  I have a 2016 Mule 4010 (model: KAF 620V).  I am having an issue since overloading the payload a couple days ago (yes I'm a dummy).  I live on a very hilly property and I was trying to move some large oak rounds for firewood splitting.  I put WAY too much wood in the bed and when I started driving, it sputtered, kicked out of gear, and then cut out.  I unloaded all the weight and started it again - appeared to be running fine when idling and/or driving on flat ground at slow speed.  But when try to go fast or uphill, the RPM's rev high and it sounds like the motor is fine, but it has ZERO speed or power at all (literally creeps uphill at like 2-3 mph and won' go faster or take any weight), and has no power at all.
      Other info: 3 weeks ago I did a belt replacement.  So I was worried I perhaps screwed that up somehow. But I just opened the clutch housing to check and the belt and clutch appear to be working just fine.... sooo.....
      Any ideas what I screwed up by overloading payload and immediately trying to drive uphill?  Any tips would be greatly appreciated!  
    • DIY like a pro! Shop from over 1,000,000 Repair Manuals at eManualOnline.com! As low as $14.99 per manual. Shop now.
    • By rsar
      Just got quoted $770 for my Mule's first 50 hour service. Is it just me, or does this seem insanely excessive? I was expecting something in the $350 to $500 range and thinking that even $500 would be a little high. Is dealer service really necessary at 50 hours? At this price I think I'd like to shop around for a mechanic that could do it for half the price. I don't really have the option of shoping around for a cheaper Kawasaki dealer, as there is just this one dealer a reasonable distance away (30 min). The next closest olne is 3 hours away.
  • Gallery Images

  • Create New...