Quantcast
Jump to content

landmaster amsportsworks


Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By OviV
      Has anyone found aftermarket side mirrors that work with angled bars on the 800sx other than the super expensive factory ones?
    • By res2fr
      Hello All,
       
       I am trying to find a Scanner that is works for a 2016 MSU500. I found the Tiny Scan TS301 that looks like a decent Scanner but so far have not been able to get confirmation that this works on and older model. It has been stated that it works on the 2019 and newer but not sure about older models. It appears that the ECM/ECU/EFI modules are likely interchangeable between a 2016 and the newer 2019 and on but not sure of the Scanner. I am waiting for feedback from Hisun on this issue right now.
       If this unit is not usable for my model year has anyone found and a Diagnostic Scanner for the older machines, one that works and is Affordable?
      Thanks for reading my post and any information that you may have to share,
      Robert
    • By Mackc
      What type and brands of insulation do you use in the cabin, floor and engine compartment of your Massimo and related 4 by 4 UtVs specially Massimo Buck 400s?
    • By Zero
      So i have a 2011 EFI 700. the SxS will crank right up everytime without any issues. If i let it run or ride it for about 10 mins it will shut off and then it may turn on if i am lucky but most time i have to let it sit for like 3 hours and then it will run again. i have done the following
      -New fuel filter
      -New injector
      -New spark plug
      -New coil pack and plug wire
      -New air filter
       
      Also could i get a grizzly 660 engine and put in it or would it not work.
    • eManualOnline
    • By Michael Black
      Has anyone in this group installed power steering in a 2019 Kawasaki KAF400PKS. If so, please advise on what type of power steering and how it went. Thanks in advance. 
  • Similar Tagged Content

    • By scotthunts
      Does any of you utv enthusiast own a "hybrid " model. I have researched for hours and the only true hybrid I could find has been discontinued since 2016. It was made by American Landmaster. I know there are a few companies that have hybrids but the gas motor on them is only a generator to keep the electric running. The Landmaster hybrid actually had a Subaru Gas engine and an electric motor as well. The electric ran the front axle and tires and the gas would run the back. To me this sounds like the perfect match but American Landmaster said they did not sell many so they discontinued them. You had a choice to run all gas, all electric, or both. The nice thing is when you ran the gas it would charge the batteries as well. I lease some hunting land and I think this combo would be excellent for me. I could run the gas to do food plots, put up and maintain stands or any other "off season" projects. During hunting season I could use the electric for a little more silent ride. What do you guys (and gals) think? Does anyone have one? Do you know of anyone? All and info positive or negative would be appreciated! Thanks in advance - Scott 
    • By Ncheek
      I am lookong into getting a utv to use around the hoise and farm, along with some easy trail riding. I won't be going crazy on the trails, but would like to take it into the woods some.
       
      Has anyone had experience with an american sports works Landmaster? I can't afford and really wouldn't want to spend 8,9 or 10 k on a ranger, rhino etc... Is this a good alt? 
    • By Josh
      I have a land master  LM 400. Starts up just fine and idles fine but as soon as I run it for a little bit it seems to start sputtering so I pulled a choke out and it runs fine for a couple seconds and then I push the choke back in and it just shuts off. Any suggestions as to why? 
    • By Chris Miller
      Good Morning Folks..Happy New Year, I have been having some intermittent issues with my 2015 American Landmaster LM500 not going into neutral. Seems if I shut the engine off it would pop into neutral. Yesterday I was splitting firewood with a 500 pound log splitter that I pushed to my wood area up a slight grade. I was not able to get it into neutral which I assumed was due to the pressure of the weight of the splitter pushing back. after I finished splitting wood, I used the weight of the splitter to roll back down the hill to my driveway. I unhooked the splitter but still could not get it to go into neutral or start. I dragged it back into my barn with my mower as I don't leave anything outside over night. I am at a loss what to check to try to fix this. I use my UTV (Eustas) every day that I am at my place where I keep it and will be lost without it. Thoughts? 
    • By Beardy13
      Has anyone ever installed a exhaust silencer on there Landmaster? I recently retired from the military and having a lot more time to deer hunt and want something to quite my utv’s exhaust so it’s not so loud going up the mountain. Thanks! 
  • Gallery Images


×
×
  • Create New...