Quantcast
Jump to content

GDS

3010 Clutch Question

Recommended Posts

I have my new to me 07 3010 running great. But I have a question It seems to rev high before the belt engages.  I put a new belt on but it didn't help. Is there some adjustment I need to look at?

Share this post


Link to post
Share on other sites


Inside the clutch is  a big spring and weights.  No adjustments I am aware of ,It could be a number of issues inside it, either the Primary or or driven clutch could be the cause.

If I remember right Comet made the clutches but they're out of business.

I think On most mules they are made to engage at 2000 rpm... If my thinker serves me right.

 

Share this post


Link to post
Share on other sites

Travis, At that RPM maybe its ok. I just know when it engages its good bump

Share this post


Link to post
Share on other sites
3 hours ago, GDS said:

Travis, At that RPM maybe its ok. I just know when it engages its good bump

mine does also  bump when going into gear

 

Share this post


Link to post
Share on other sites


Best thing to do would be buy a tachometer and see at what RPM it engages it. Not a permanent one , unless you want it to be.

they make some you just wrap the wire around the spark plug or plug wire.

Share this post


Link to post
Share on other sites

We used to use a little white lithium grease on snowmobile comets, they had all different weights and springs for engagement at different rpms. Old sleds shops might have nos laying around, cant be much different.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By GDS
      I have been looking for a cab enclosure for my 3010. I accidently came across one for a 4010 on Amazon for $27. 00. I could not find out if it fit or not but for 27 bucks I figured I would try it. It fit better than I thought it would. If you don't have a windshield, you will have a good gap at the bottom. But with a wind shield it works great. Enough that I ordered a second one  for later. 
      Just figured I would let people know. 

    • By wilec
      how much should I expect to pay for a CF Motto 800 EX with an MSRP of $11,799?  Thanks
    • By dant849
      This looks to be a pretty common topic and I've had issues with mine overheating since I got it back around the end of 2019. Started running hot again, thermostat was not opening and they sent me a new one. Installed that, burped the system for air all to no avail. Next in line is the water pump to replace, they sent me a water pump and when I got the old one off it was not turning freely to say the least so I'm thinking that could have been my problem. My issue now is getting the slot in the water pump shaft to line up with the tab inside the engine of the machine. Any tricks to doing this? Thanks in advance
    • By miten000
      What aftermarket belt do you all use that fits...my dealer used the DAYCO XTX 2236...???
    • By Julie Doeppke
      We bought a Hisun 700 UTV, used. It has an issue when you run it in high. It drives but acts like it is shifting when you get around 35mph. Clutch looks good. Read many articles and not sure transmission or something in rear of UTV. Looking for any advice.     


×
×
  • Create New...