Quantcast
Jump to content

Bricklayer

New to UTV Board.... May have been a member of previous board...

Recommended Posts

.Hi I'm new to UTV Board,  used to be a member of a rhinoclones forum that changed its domain to something like UTV board...

Is this the same forum? 

I had a hisun 700 now have a rhino 660. 

 

Thanks!

John

Share this post


Link to post
Share on other sites




Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By EJR
      I have a 2012 Coleman (hisun) hs700. The cooling fan quit working. I replaced the water temp sensor/ radiator fan switch located towards the bottom of the radiator. That did not cure the problem. I also put 12v directly to the fan to make sure the fan was still good. I then took the harness off the new temp sensor and shorted it to turn on the fan and nothing. Is there something else in line I should look at? I also found the sensor at the motor and jumpered through it. Still did not work.
      Any suggestions? 
      Thanks
    • By Mick
      So had nuthing but trouble w this machine since I got it. New fuel pump new fuel injector. Now no spark and seem like sometimes no injector pulse?  2019 Hisun Sector 550. Any ideas?? Wiring diagrams seem to be impossible to find. 
    • By Mattg1717
      I have a 2018 gator RSX I installed a 2” lift and am wondering what size tires I can fit. 31s? 32s? Any input appreciated 
    • By Randy Stevens
      Hey all, I bought a Hisun 550 back in June of 2019. After 6 weeks of ownership, this machine took to sputtering when started and under power. I checked everything I could think of before I took it back to place of purchase....(rural king), since it had a one year warranty.   They kept it almost two months stating they were waiting to get info from Hisun to rectify the issue (supposedly faulty drivers seat belt). I was told by the tech that they replace seat belt harness and cured the problem. It did! Ran just fine again for almost a year and now the very same issue has returned. After doing a little investigating on my own, I noticed that rural king did not replace the seat belt harness at all.  The wires to seat belt connector was cut and spliced and taped back together. Now I’m not real sure what the real problem is as that tech is no longer with company and can’t seem to locate the past work order for my machine.  Hisun customer service is non existent . I’m on my own and begging for help. Im mechanically inclined but if this is an electricical issue, I’m screwed! No warranty left. Any help would be gratefully appreciated.
    • By Mick
      So like a lot of other Hisun owners I am having fuel injector problems, put a new one in and now a few weeks later I have no injector pulse. Does anyone know where I can find some wiring diagrams?? Its a 2019 Hisun Sector 550.  Thanks for any help!


×
×
  • Create New...