Jump to content

Recommended Posts

son got an old qlink sxs, at first wasnt starting good and was leaking fuel very bad out carb and pooling under it. had a hose off that seemed to go from tank to highest nipple on carb..... put hose back on, cleaned carb, and plug. now doesnt leak and cranks fine, but once engine warms wants to cut out back fire and die.....will crank right back up and idle fine until give throttle ....i mean looks like a carb to me ........has fuel pump though.....i dunno if those two will even work correctly together, does this sound right? or did someone just try to force this to work? please help!!!!!

Link to post
Share on other sites
10 hours ago, Travis said:

post some pictures if you can.

you'll probably need to remove the carburetor and clean it thoroughly.

^^^This^^^ 99.44% of the time now, with this damned ethanol gasoline, you'll find a jellied up ball of crap in the float bowl or diaphragm cavity if a diaphragm carb...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By T-boss 410
      I guess this is one for the general forum. Does anyone experience a  slow turn over by the starter? I had a battery with a bad cell, and it was replaced. It wouldn't even turn over. Now it will start, but I have to hit the key a few times before it will spin over fast enough to start. The battery is a 330cca unit, so I would think that it would easily spin a single cylinder engine. This is for a Massimo T-boss 410. The engine is a 352cc, 25.5hp fuel injected unit. 
      Where should I start looking? It's a 2019 UTV, with only 14.6 hours on it. In my mind, I can only think that the connections somewhere are loose, or the starter is not up to snuff. Could tracing the wires for the starter system be difficult? Is there a way to test the starter?
      Thanks much!
    • By bjones
      2007 Mule 610,  owned for 8 yrs and valves were ticking when I got it and had them adjusted twice and this is when plugs began to foul.  I replaced battery (used battery I had on hand) a yr ago and didn't foul a plug for some time and replaced batter (new) with a bigger lawn mower type battery again a month ago and have fouled two plug since.  Had carb cleaned and valves adjusted and still fouls plugs way to often.  Friend has a mule just like mine and his does same thing. Have read this is a common problem with 610 mule.  Any help or suggestions would be welcomed.  Thanks and stay healthy.
    • By res2fr
      Hello All,
       I'm not really New here but Life sidetracked me for the 18 months or so but I've gone back to doing some work on my Coleman(Hisun) UTV400 SxS that has a Kodiak 400 motor/Trans and a Major wiring problem. 
      Short history, with original owner there was a fire, some interior plastic damage but were told major fire damage to motor. They bought and installed the Kodiak 400 motor, CDI box and a few other necessary parts. They had someone wire it and used it then for some reason Stripped the wiring, installed a new Emark wiring harness but Never reconnected the motor wiring to the Machine. There was a mountain of loose wires, cut off connecters in the Dump Box.
      I've finally gotten back to sorting and reading diagrams for both machines wiring and have the CDI box rewired in to the point I can start the motor with my Temp ignition switch, it runs ok and is charging the battery. my immediate problem with the motor right now is that it runs fine At Idle but if I try to accelerate it immediately  Dies. Im trying to figure out if it's an issue with something that the CDI box needs wired that isn't there, some switch or relay connection that's still not there Or the fact that the fuel supply being from and electric fuel pump not the original Vacuum pump that the Quad used was, I cant find the Pressure of the Vacuum pump.  Acts like there's no Spark Advance in a way but could be just getting way to much fuel, to fast. I have a valve I found that allows me to cut the pump pressure down to 1 PSI that I'm about to try and I'll keep checking the wiring diagrams looking for something electrical that might help explain this. Oh I couldn't a carb kit to rebuild with so I bought a New carb, not high end but figured it should make a difference but no such luck.
      Once I get past this issue I'll go back to paying attention to getting battery power back into the new Emark Harness so I can start getting power to the rest of the machine.
      Sorry all, I got a touch Wordy here. I hope to be spending more time here and Learning and if at all possible  Helping others.
      Take care all and I Shall Return.
    • By Greg Beachy
      I have had a Bad Boy Stampede for almost two years now. I really like the machine but it seems like everytime I run it over 40 mph for more then a couple hundred yards it starts leaking antifreeze. The mechanic says it's a seal in the water pump, I've went through three water pumps now. Does anyone else have this problem?  And if so is there a fix for this? 
    • By Honda533
      Machine sat and had multiple rodent chews thru out the wiring that we fixed.  Also replaced the Following: ECU, Coil and Plug Wire, small Control Box that contains fuses and relays.  Pick Up coil test at 219 ohms which is typically good on most machines but i can't find the specific manual on this thing to get the spec.  Battery good, cranks fine but the fuel pump doesn't prime or run and no spark.  Tested pump with direct 12volts and it works.  If we supply a ground to the pump it primes and works but still no spark.  We have traced all wiring including grounding and all is good. Tested key switch.  I has (4) positions.  1 - off, 2 - does nothing, 3 - powers up everything (lighting and odometer and powers ECU, 4 - starts engine.  The key switch only has 3 wires. 12v in from battery and 2 - 12v out which is power to the system and send 12v to starter relay coil.
      Are these electrical systems actually switching the grounds on and off vs the traditional switching the 12v+ on and off.  
      at my wits end with this thing. 
      Also when we figure this problem out we will post the solution.  seems 90% of people that ask for help on these forums, never post the fix which make this pointless.
  • Similar Tagged Content

    • By Mark Popeye
      Hi,  Just purchased a 2010 Qlink Frontrunner 700.  Using it to plow my yard (just moved back to NH).  I knew it had starting issues but that was mostly around the starter relay (as shown, when I was looking at it).  I rewired (and soldered) the 4 wires that go to relay, replaced the relay, starter and battery.  It still starts extremely hard but runs great.  I don't know what else to check.  On another topic, which way do wheel hub nuts turn to loosen?  TIA.

  • Create New...