Quantcast
Jump to content

Recommended Posts

So last night I was changing out my starter solenoid, and like an idiot, I didn't disconnect my battery.  wires made contact, a spark went up and the engine even tried to turn over for a second.  But now I have no power at all.  Which to me means something blew. I know you can have power to the dash and the ignition won't work, but I'm not getting anything.  I looked at the fuses and they look ok.  But I don't know how to tell if the larger black ones are bad or not.  Any ideas? Can the voltage regulator get blown up? are there fuses I'm not seeing? I see on that's at the end of a red wire near the battery but that doesn't look blown either.  Hello!!!!! Moab trip planned in one week!

Link to post
Share on other sites

if you have a electrical meter/tester  set it to continuity, (beeps when you touch the probes together) and use that to check the fuses.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Mike_Metzger
      Thought I’d post this in the general forum to try and get some more ideas. 
      2008 Joyner Renegade
      800cc EFI Chery engine
      1100mi
      Starts and idles fine, drives well until you actually try to go, then starts to sputter as if it’s starving for fuel. Does this no matter what fuel pressure I set it too. I’ve tried 35-80psi 
      New fuel pump
      New fuel filter
      Cleaned injectors
      New thermostat
      Fresh Fuel
      Any smarty smarts out there with ideas? 








    • By Amyjou
      Our 2017 Textron Stampede 900 died when driving it (after making a terrible noise).  Now it won’t start. Checked oil and there wasn’t any.  Was given advice that the engine would need to be replaced. Trying to find a used or rebuilt one.  Any recommendations or leads on how I can find one?
    • By CanyonCarver
      Not sure if this has been discussed before but here it goes; 
      If i lower a utv and put some more grippy/less of roading tires, can it handle like a go kart? Especially the 4-seater ones?
       
    • By calebcobb1994
      There is no spark to plug and no power to fuel pump. I can run a direct ground to fuel pump to get power but still no spark at plug. Any ideas to what could be wrong? thanks!!
    • eManualOnline
    • By Travis
      I've always adjusted small engine idles by ear.....  but i finally decided to buy a tachometer... it came in the mail today so i tried it out on the mule. it's the kind that wraps around the plug wire.
      fire the mule up, the idle RPM spec in the manual  is 1,300...  and the way i have it adjusted now it was idling at 1,260, let it warm up and bumped it up to 1300, which wasn't much
       

×
×
  • Create New...